Missfire at 4000RPM - but only in Neutral ?

Discussion in 'Engine' started by Cool Mart, Sep 28, 2008.

  1. Cool Mart

    Cool Mart Member

    Messages:
    56
    Joined:
    Oct 22, 2006
    Location:
    Hemel Hempstead
    Car:
    S430, Marcos Mantaray 4.6
    G'morning,

    The car's an S430.

    As per the title really, can't remember the last time I revved the car in neutral, but I've just tried it and it goes quite lumpy at 4000RPM almost like a crude rev limiter, and won't rev past 4500.

    Took the car for a sprint up the road and back and it's fine - doing 80MPH in 2nd without missing a beat.

    A missfire I can understand, but one that only occurs in Neutral ??

    Any ideas ?

    Thanks

    Martin
     
  2. bolide

    bolide Hardcore MB Enthusiast

    Messages:
    3,726
    Joined:
    Oct 8, 2005
    Location:
    Brighton
    Car:
    BMW E39 525 Diesel Touring
    The no-load rev limit is 4k. So this is normal

    Nick Froome
    www.w124.co.uk
     
  3. OP
    OP
    Cool Mart

    Cool Mart Member

    Messages:
    56
    Joined:
    Oct 22, 2006
    Location:
    Hemel Hempstead
    Car:
    S430, Marcos Mantaray 4.6
    Thanks for the quick reply Nick ..... that saved me sulking until Monday when I could get to the garage ! :)

    Martin
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.