ml 270 cdi - electric heated seats not working

mustang

Active Member
Joined
Feb 21, 2009
Messages
85
Location
kent
Car
ml 270 brabus d4,
hi all . my both front electric heated seats are not working. they both operate correctly at the switch on the dash and the sinlge light then the double light comes on . they do not flash as they say they do if there is a fault re- the owners manual. i have checked all fuses under the bonnet and nothing wrong there. so i have dropped the contol boxes under each seat down and nothing seams blown or burnt out. when i push the heated seat button on the dash the contol panels under the seats click on ( presume relays ?) 1 thing i did find was that the contol boxes click on and off for the other seat. so it seems they are not switching/clicking for that seat but for the other one so is that normal ? also there is 1 less plug under the drivers seat to that under the passengers seat and i think the 1 missing is a white plug and says orange on the box wiring indicator for the plugs , i have looked all under the seat and cant find it ( thought it may have been pulled out ) so presume that is how they are wired ? "1 less plug under the drivers seat ? "

any ideas or things to check ? the electric seat adjustments are fine and the preset memory buttons are fine. just the heated seats.

its a ml 270 cdi 2001

cheers shaun
 

andy27168

MB Enthusiast
SUPPORTER
Joined
Nov 27, 2004
Messages
4,446
Location
Southampton
Car
1997 C230K, 1999 C43/55 AMG
Hi,
Can,t help regarding why the heated seats are not working, though it does sound like a fuse is blown but as you have checked them it can,t be, though i can shed some light on the one less plug under the drivers seat, it because the passenger seat has an occupancy sensor pad for the SRS (Airbag system). IIRC you should have a yellow plug extra on the passenger seat.
 

Jane270ML

Active Member
Joined
Jan 22, 2012
Messages
326
Location
Leeds/Harrogate
Car
ML 270 Cdi
I understand there is a fuse connected to the positive pole on the battery - have you checked this?

It controls heated seats & electric radiator fan & sometimes throws-up a coolant warning light on the dash.

About £10 from MB.
 
OP
OP
mustang

mustang

Active Member
Joined
Feb 21, 2009
Messages
85
Location
kent
Car
ml 270 brabus d4,
hi all.

thanks will have a look for that one .
 

simonafloat

Member
Joined
May 18, 2013
Messages
57
Location
Bideford, North Devon
Car
ML270 CDI
hi all.

thanks will have a look for that one .
Just resurrecting this post, did you find a solution to this one? I have an identical problem with my ML270, the heated seat signs come on, don't flash and I can hear the relays working. None of the heated seat panels work.

Thanks

Simon
 

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

Top Bottom