ML boot closure problem

Discussion in 'Electronics' started by S2YOB, Aug 25, 2014.

  1. S2YOB

    S2YOB New Member

    Messages:
    20
    Joined:
    Aug 25, 2014
    Car:
    ml320 cdi
    Afternoon,

    My wife has an ML 320cdi 06 plate.

    She was driving along today when the tailgate made the noise that it was opening...... and it did!!!!! (it has the soft close and power open function).

    I managed to get the car home and play with the lock, but it has now got the problem that the tailgate will open and make all the right sounds and noises, but it will not close. The red button in ht tailgate doesn't work, and if i hold the boot shut button on the remote it goes to close then stops after 2/3 seconds.
    If i force close it, the rear lights stay on and the car says the tailgate it open!?!?!

    Any ideas as it raining and i am getting wet :mad:

    Thanks

    Nick
     
  2. boxbrownie

    boxbrownie Hardcore MB Enthusiast

    Messages:
    1,420
    Joined:
    Jan 20, 2013
    Location:
    Pastyland
    Car:
    ML350Cdi BE now replaced, E220 2013MY just for a bit.....
    An umbrella? :thumb:
     
  3. boxbrownie

    boxbrownie Hardcore MB Enthusiast

    Messages:
    1,420
    Joined:
    Jan 20, 2013
    Location:
    Pastyland
    Car:
    ML350Cdi BE now replaced, E220 2013MY just for a bit.....
    Ok...failing that......I had something like this happen on my ML, where the tailgate (albeit not whilst driving) suddenly got a mind of its own and would open just about 18" then stop and not move when the button was pushed, in the end I had to lift it open physically fully, and then close it using the electric close, it then after that behaved itself until I sold it.
     
  4. OP
    OP
    S2YOB

    S2YOB New Member

    Messages:
    20
    Joined:
    Aug 25, 2014
    Car:
    ml320 cdi
    i like the umbrella quote lol

    Its driving me insane, as the boot won't shut, so i just forced it. But the motor keeps trying to work even though the car is locked and no key in ignition, and now the brake lights are stuck on :mad::mad:

    Nick
     
  5. Merc Owner 2B

    Merc Owner 2B Hardcore MB Enthusiast

    Messages:
    1,009
    Joined:
    Dec 3, 2009
    Location:
    Leicestershire
    Car:
    2012 ML250 Sport BlueTec
    I had the tailgate lift motor replaced when mine failed. Fortunately under warranty. If you've got full MB service history they may look favourably at it as there's a new modified version available.
     
  6. OP
    OP
    S2YOB

    S2YOB New Member

    Messages:
    20
    Joined:
    Aug 25, 2014
    Car:
    ml320 cdi
    Would that cause to open, but not shut?

    Nick
     
  7. Merc Owner 2B

    Merc Owner 2B Hardcore MB Enthusiast

    Messages:
    1,009
    Joined:
    Dec 3, 2009
    Location:
    Leicestershire
    Car:
    2012 ML250 Sport BlueTec
    The motor is built into the offside strut and contains various limit switches.

    Connecting to MB STAR gave various fault codes relating to failure of limit switches that gave false reports of opening and closing.

    I would suggest that getting it plugged in at a good independent or local dealer was the best place to start
     
  8. boxbrownie

    boxbrownie Hardcore MB Enthusiast

    Messages:
    1,420
    Joined:
    Jan 20, 2013
    Location:
    Pastyland
    Car:
    ML350Cdi BE now replaced, E220 2013MY just for a bit.....
    Can you open the tailgate fully? And will it stay open when there? If so try it and then close using the motor if possible, sounds like when mine went array it needed the "limits" reset, although at the time I didn't know thats what I was doing.

    Possibility, hopefully.
     
  9. OP
    OP
    S2YOB

    S2YOB New Member

    Messages:
    20
    Joined:
    Aug 25, 2014
    Car:
    ml320 cdi
    Cheers,

    It fully opens, but only closes about 4 inches and then stops.

    I will take it to one of my customers tomorrow who is a merc Benz specialist.

    Thanks

    Nick
     
  10. Jane270ML

    Jane270ML Hardcore MB Enthusiast

    Messages:
    326
    Joined:
    Jan 22, 2012
    Location:
    Leeds/Harrogate
    Car:
    ML 270 Cdi
    Try pulling the fuse for a few minutes to see if it resets.
     
  11. OP
    OP
    S2YOB

    S2YOB New Member

    Messages:
    20
    Joined:
    Aug 25, 2014
    Car:
    ml320 cdi
    It was the SAM unit, now needs to be replaced

    Nick
     
    2 people like this.
  12. Merc Owner 2B

    Merc Owner 2B Hardcore MB Enthusiast

    Messages:
    1,009
    Joined:
    Dec 3, 2009
    Location:
    Leicestershire
    Car:
    2012 ML250 Sport BlueTec
    Expensive?
     
  13. OP
    OP
    S2YOB

    S2YOB New Member

    Messages:
    20
    Joined:
    Aug 25, 2014
    Car:
    ml320 cdi
    Luckily i am a manager at Euro car parts and have a very good Mercedes customer who is helping me out

    Nick
     
  14. Merc Owner 2B

    Merc Owner 2B Hardcore MB Enthusiast

    Messages:
    1,009
    Joined:
    Dec 3, 2009
    Location:
    Leicestershire
    Car:
    2012 ML250 Sport BlueTec

    We are great fans of ECP so welcome to the forum :)
     
  15. OP
    OP
    S2YOB

    S2YOB New Member

    Messages:
    20
    Joined:
    Aug 25, 2014
    Car:
    ml320 cdi
    Thank you :)

    Nick
     
  16. Richc7

    Richc7 New Member

    Messages:
    2
    Joined:
    Mar 2, 2013
    Car:
    w164
    Was it water damage to the SAM, Ml's are know to leak at the rear.
     
  17. OP
    OP
    S2YOB

    S2YOB New Member

    Messages:
    20
    Joined:
    Aug 25, 2014
    Car:
    ml320 cdi
    Yeh funny it was :confused:

    They said it was soaked in water, so i must have a leak.

    Nick
     
  18. Richc7

    Richc7 New Member

    Messages:
    2
    Joined:
    Mar 2, 2013
    Car:
    w164
    Could be getting in via rear light seal, side window or roof rails.
     
  19. Jane270ML

    Jane270ML Hardcore MB Enthusiast

    Messages:
    326
    Joined:
    Jan 22, 2012
    Location:
    Leeds/Harrogate
    Car:
    ML 270 Cdi
    Not sure if it's in this forum, but I've seen it somewhere, that W164's are prone to water entering the air extraction vent near o/s rear wheel arch affecting electrics, deep puddles or even a jet wash.

    I think it's bumper off to check/sort.

    Protect SAM in a weatherproof cover, but be aware of heat build up and lack of heat dissipation.
     
    Last edited: Aug 26, 2014
  20. OP
    OP
    S2YOB

    S2YOB New Member

    Messages:
    20
    Joined:
    Aug 25, 2014
    Car:
    ml320 cdi
    Gonna have to look at this stuff, its my wife's car and she has just told me she has had water dripping from by her interior light!!!!! So wondering if somewhere a drain away is blocked

    Nick
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.