ML270 Auto box not engaging neutral

rbanwell

New Member
Joined
May 23, 2011
Messages
5
Car
ML270
Hi.
I have a 2005 ML270 and have a problem with the automatic gearbox.

When I apply the brakes in order to stop completely, it does not engage itself into neutral. So although I'm stationary with the brake on, the car is still trying to pull forward.
My temporary solution is to slip it into neutral using the gear shift as I approach a junction and back into drive in order to pull away.

My local independant has cleared down all the histroical error codes and none have reappeared although the problem persisits.

It has had the problem for a few weeks now but doesn't appear to be getting any worse.

Any ideas?

Thanks.
 

BlackC55

Authorised Forum Sponsor
SUPPORTER
Joined
Feb 8, 2007
Messages
19,541
Location
Portsmouth, Hampshire.
Car
E55K SL500 E300Hybrid E250X3 Viano C55 E450Cab A180 Smart 44 Brabus
It is not supposed to engage into N when in D with your foot on the brake.
 
OP
OP
R

rbanwell

New Member
Joined
May 23, 2011
Messages
5
Car
ML270
It is not supposed to engage into N when in D with your foot on the brake.
Sorry, I'm not too technical.
The problem I have is that the car is trying to pull away when I'm sat at a junction with my foot on the brake.
 

gtvlusso

Active Member
Joined
Dec 22, 2009
Messages
322
Car
Bicycle and a couple of ML's
Hi,

Yes, all automatic cars will "creep" or pull a bit when in "D" - "N" is only engaged when you select "N" on the gearshift.

stronger foot on the brake pedal.....
 
OP
OP
R

rbanwell

New Member
Joined
May 23, 2011
Messages
5
Car
ML270
Hi,

Yes, all automatic cars will "creep" or pull a bit when in "D" - "N" is only engaged when you select "N" on the gearshift.

stronger foot on the brake pedal.....
Thanks for the reply.
This is more than a creep. It's really pulling forward - when I take my foot off of the brake it jumps forward.
 

BlackC55

Authorised Forum Sponsor
SUPPORTER
Joined
Feb 8, 2007
Messages
19,541
Location
Portsmouth, Hampshire.
Car
E55K SL500 E300Hybrid E250X3 Viano C55 E450Cab A180 Smart 44 Brabus
I would say that you have an internal fault with the gearbox. It needs to go on a Star diag machine to double check. Did your independent use a Star?
 
OP
OP
R

rbanwell

New Member
Joined
May 23, 2011
Messages
5
Car
ML270
I would say that you have an internal fault with the gearbox. It needs to go on a Star diag machine to double check. Did your independent use a Star?
Thanks. No he didn't use a Star but is now on the case!
 

pmcg

New Member
Joined
Dec 16, 2011
Messages
1
Car
ML270
Thanks. No he didn't use a Star but is now on the case!
Hi. i have exactly the same problem. My independent guy doesn't seem to have a clue as to what the issue is and has also said there were no faults showing.

I would be really interested to know the outcome of the Star diagnostics - did it show anything and did you manage to get the issue resolved?

thanks and kind regards,

Paul
 
OP
OP
R

rbanwell

New Member
Joined
May 23, 2011
Messages
5
Car
ML270
I'm ashamed to say that I'm just living with it at the moment. It doesn't seem to be getting any worse. The nearest available Star diagnostic is not particularly close for me so will involve a bit of effort. Still intend doing it though!
Sorry I couldn't be more help.
Please let me know if you manage to sort yours.
 

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

Top Bottom