ML320 Gear Selector Stuck in P

Discussion in 'Engine' started by aqib, Apr 18, 2014.

  1. aqib

    aqib New Member

    Messages:
    5
    Joined:
    Jan 16, 2010
    Hi all

    I have a 2000 W-Reg ML320.

    Recently I had a problem with it being stuck in limp mode and it seemed not to be getting out of 1st gear. Also the dash was not showing the P/N/R/D.

    I bought a second hand gear selector and have just put it in.

    The good news is that the car does now drive properly and goes smoothly through the gears as normal.

    The BAD news is that it is stuck in P and only using a pencil to release it manually can get it driving.

    My brake lights are working and earlier the old gear selector was coming out of P fine.

    Any ideas what could be the problem?
     
  2. renault12ts

    renault12ts MB Club Veteran

    Messages:
    14,666
    Joined:
    Mar 5, 2009
    Car:
    2005 W215 CL500.
    Just because your brake lights work does not mean the brake light switch is working as it should...change it.
     
  3. OP
    OP
    aqib

    aqib New Member

    Messages:
    5
    Joined:
    Jan 16, 2010
    I don't mind doing that but I'm wondering why the brake light switch would go at that point when it was working fine earlier the same day.
     
  4. OP
    OP
    aqib

    aqib New Member

    Messages:
    5
    Joined:
    Jan 16, 2010
    I have now ordered a brake light switch from the dealers but does anyone know any other reason the selector might not be coming out of Park?
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.