MOODY CRUISE CONTROL / DISTANCE PILOT

MEMERC7

Active Member
Joined
Oct 11, 2013
Messages
154
Car
SLK 250 AMG Sport 125 Ltd Edition
Decided to stop working during the course of a days driving. Ditto the next day then the following day all was fine. Local specialist found no fault.
Today again stopped working. After parking up for about 10 minutes all services resumed. Why? At 49k miles a previous Mercedes required a set of wheel sensors to solve the same problem.
A Ford Mondeo, Vauxhall Vectra & an Audi A3 all did 150+k miles & cruise NEVER stopped working ditto wife's Honda Jazz so why Mercedes who apparently are deluded as to quality & reliability? Am I supposed to be so impressed by the brand & ignore this? I just wish Audi or Honda did a folding hardtop convertible.
 

Stratman

MB Enthusiast
Joined
Jun 15, 2003
Messages
5,145
Location
Sunbury
Car
W203 C200 CDI '04Estate
Have a good check of the battery, a dodgy one can cause all sorts of seemingly unrelated problems.
 
OP
OP
M

MEMERC7

Active Member
Joined
Oct 11, 2013
Messages
154
Car
SLK 250 AMG Sport 125 Ltd Edition
Have a good check of the battery, a dodgy one can cause all sorts of seemingly unrelated problems.
Good idea. Thanks. Maybe have a new battery fitted (I assume you mean the main 12v one). The car has only done 27k miles but my use is a few miles a couple of days a week & only one long run. Purchased with 25k miles so no idea how it was used prior to my purchase.
 

Stratman

MB Enthusiast
Joined
Jun 15, 2003
Messages
5,145
Location
Sunbury
Car
W203 C200 CDI '04Estate
Yes, the main 12V battery. With such low use it may just need a good charge but having it properly checked is never a bad idea.
 
OP
OP
M

MEMERC7

Active Member
Joined
Oct 11, 2013
Messages
154
Car
SLK 250 AMG Sport 125 Ltd Edition
Maybe have it checked AND buy a trickle charger? Haven't bought one for years not since owning classic cars & I understand I can connect one to a couple of terminals in the engine bay rather than the battery direct. No need to top up battery with distilled water then !!!!
 
OP
OP
M

MEMERC7

Active Member
Joined
Oct 11, 2013
Messages
154
Car
SLK 250 AMG Sport 125 Ltd Edition
Did it again today. Lost cruise/distance pilot, tried 15 minutes later & all was well. Dodgy connection somewhere as well as battery?
Have got a brilliant independent Mercedes specialist down the road who mainly restores & services the classics but all the staff are Ex Mercedes factory trained & are current on the moderns as well. Will get battery checked & because one of the roof covers is poorly aligned will get that fixed too. Ideally want to turn up with cruise u/s which might make finding the fault easier.
 

V6GBJ

Active Member
Joined
Mar 4, 2019
Messages
284
Location
North Wales
Car
SL400 R231, GLE 350d W166
Did it again today. Lost cruise/distance pilot, tried 15 minutes later & all was well. Dodgy connection somewhere as well as battery?
Have got a brilliant independent Mercedes specialist down the road who mainly restores & services the classics but all the staff are Ex Mercedes factory trained & are current on the moderns as well. Will get battery checked & because one of the roof covers is poorly aligned will get that fixed too. Ideally want to turn up with cruise u/s which might make finding the fault easier.
We were touring last week in the SL400 and on Wed morning at startup got 3 messages :
Active Blind Spot Assist inoperative
Active Lane Keeping Assist Inoperative
Active Brake Assist Functions Limited

These are all linked to the radar beam from the unit at the top of the windscreen. I cleaned the screen but it made no difference. The same messages arrive daily so booked into my local Indie on Wed.
Mine is the fancy cruise control with the automatic safe distance facility. Any similar experiences ?
 

Users who are viewing this thread

Top Bottom