Motorway vibration only when giving gas

Page may contain affiliate links. Please see terms for details.

M.A.94

Active Member
Joined
Mar 2, 2016
Messages
307
Location
Newcastle upon Tyne
Car
2001 Mercedes E320 CDI (W210) OM613
Hi,

I have a 2000 W210 E320 CDI. I am getting severe vibration driving at speeds north of 60mph. I have ruled out wheel balancing and prop shaft bearing etc as the vibration only occurs when I have my foot on the gas pedal, as soon as I let go of the accelerator the vibration goes.

So for example 60mph on the motorway with my foot on the gas pedal the vibration is there. 60mph on the motorway with my foot not on the gas pedal there is no vibration. Anyone had similar symptoms in the past and able to point me in some direction.
 
Hi,

I have a 2000 W210 E320 CDI. I am getting severe vibration driving at speeds north of 60mph. I have ruled out wheel balancing and prop shaft bearing etc as the vibration only occurs when I have my foot on the gas pedal, as soon as I let go of the accelerator the vibration goes.

So for example 60mph on the motorway with my foot on the gas pedal the vibration is there. 60mph on the motorway with my foot not on the gas pedal there is no vibration. Anyone had similar symptoms in the past and able to point me in some direction.
I had this happen to my C320 changed thrust arms the rubbers where shot took for good run up M1 and A1 no viration so far
 
I had this happen to my C320 changed thrust arms the rubbers where shot took for good run up M1 and A1 no viration so far
thank you mate. I’m going to jack the car up in the morning and check everything out. I will check out the thrust arms and let you know how I get on. Another thing I wana check is the gearbox mount.
 

Users who are viewing this thread

Back
Top Bottom