my first amg....w210 e36

Discussion in 'AMG Lounge' started by J7GKL, Mar 30, 2014.

  1. J7GKL

    J7GKL New Member

    Messages:
    4
    Joined:
    Mar 15, 2014
    Car:
    W210 E36 AMG
    Hiya everyone as I've brought myself a 1996 e36 w210,I thought I'd start a thread about it and the ideal of being able to restore the car to a good condition, it has covered 125k and if I'm honest is pretty rough around the edges, it has the rust patches on the bottom corners of the wings and doors and they have been painted over?! It does seem however to be solid underneath. The only other issues seem to be tired suspension and an occasional odd idle that seems to hunt etc. I know most would say why?! Or break it but it was very cheap and I love it to bits! Any advice on these cars would be gratefully received and I'll add some pictures when the app lets me,
     

    Attached Files:

    1 person likes this.
  2. OP
    OP
    J7GKL

    J7GKL New Member

    Messages:
    4
    Joined:
    Mar 15, 2014
    Car:
    W210 E36 AMG
    ForumRunner_20140330_002038.jpg



    ForumRunner_20140330_002051.jpg
     
    1 person likes this.
  3. Mad James

    Mad James New Member

    Messages:
    4
    Joined:
    Apr 1, 2014
    Car:
    Mercedes E36 AMG (W210)
    Hi there,

    I also purchased my E36 just before the start of the new year, which is virtually identical to yours. For the price I paid for it I simply thought it was too good to pass up. It has been laid up since purchase & I'm now in the process of getting it taxed & re-insured. In the interim I've been doing a bit of homework on what problems I maybe faced with when she's up & running. On driving her back from Glasgow when I purchased a few months back, there seemed to be a rumbling from the rear passenger side area when braking. The car is vistually rust free due to the previous owner having the wings re-sprayed a bit back. I'm only intending to use her through the summer months, which should keep the well renowned corrosion issues away for a while. Also seems to be an issue with the remote locking. Seems as if it drains the battery when I use it, so for the time being I'm resorting to manually locking. The battery under the rear seat also seems to make an intermittent ticking noise for around a minute, when you turn the ignition on. I also seem to have buggered the auto sunroof last week. It was working fine but when sliding the sunroof back, it stopped with the motor still running, It still closed & tilted, but on closer inspection it looks like one of the plastic rods has snapped which helps retracts the sunroof. Unsure if this is an inexpensive fix?? Also have you noticed a difference in the shade of the silver paintwork between the doors & front & rear wings? Might be something to do with the re-spray my car has undergone. My car came with very basic spec. Even with £55k price tag in 1997, Mercedes offered a lot of options in which the original owner didn't go for. It doesn't even have electric folding mirrors, but I can't seem to fold the mirrors manually which is strange. Due to the rarity of this model which they only produced for one year & less than 400 supplied worldwide in 96 & 97. I'm willing to spend a bit of time & money to get her back to her former glory. But would be interested to see how you go on with yours moving forward, with you also being a first time E36 owner. Any feedback on my aforementioned points would be much appreciated?
     
  4. John Jones Jr

    John Jones Jr Hardcore MB Enthusiast

    Messages:
    4,621
    Joined:
    Mar 23, 2013
    Location:
    London & Dublin
    Car:
    Mazda MX5 10AE, W201 2.5-16, W202 230K Sport man, Honda Accord & Suzuki 'Ricer'.
    Good stuff, nice project too and half the fun is getting the car sorted. Looking forward to the thread. :thumb:
     
Tags:

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.