need help with cl420

john uk

New Member
Joined
Feb 21, 2011
Messages
6
Car
1998 cl 420
guys on my car in the morning or when its cold when i start the car the choke comes on as normal but the bas asr light comes on eng runs ruff smells like gas so i kill the car and start it up and add some gas ad its ok let it warm up for 30 sec and its good runs very good and if i drive it rund good and if i kill car for a few hours and start it up its good only when compleaty cold and 1 can help me plz leav comments
 

BlackC55

Authorised Forum Sponsor
SUPPORTER
Joined
Feb 8, 2007
Messages
19,796
Location
Portsmouth, Hampshire.
Car
E55K SL500 E250X2 Smart44 Brabus Track car E450Cabriolet X350 Pick up
I can't quite understand what your problem is?
 
OP
OP
J

john uk

New Member
Joined
Feb 21, 2011
Messages
6
Car
1998 cl 420
when i start the car in the morning for the first time car is cold and when i do the eng light comes on and the car running not right like shanking its like limp mode i push on the throtle and wont rev up so i kill the car start again but with a little throtle till its warm up then its fine
 
OP
OP
J

john uk

New Member
Joined
Feb 21, 2011
Messages
6
Car
1998 cl 420
so does any1 had ever had this problem any one know how to solve it
 

jaymanek

Authorised Forum Sponsor
SUPPORTER
Joined
Nov 29, 2002
Messages
16,415
Location
Nuneaton Warwickshire
Car
Lots of Mercedes!
Ok so you have some kind of running issue when cold?

If the engine light is on you may be able to pull the codes which will help.
 

Users who are viewing this thread

Top Bottom