need help

Page may contain affiliate links. Please see terms for details.

biskit69

New Member
Joined
Jul 1, 2023
Messages
2
Location
cornwall
Car
sprinter 313 cdi
2011 sprinter 313 cdi 230,000mile

ive been having some ,apparently typical, problems with my sprinter for a few months now. It originally started with a blown exhaust manifold gasket which eventually lead to turbo boost issues and limp home mode. i got the exhaust manifold replaced and skimmed the manifold, stopped the squeal, but didnt fix turbo boost issues. Ive done the whole "needlessly replacing parts" bit and realised this could go on for some time. after replacing lambda, atmospheric sensor, exhaust back pressure sensor and also finding a leaky turbo solenoid, after vacuum testing the system. i then went to "reset adaptive settings" on my icarsoft v3.0 and i was met with a message

"prerequisite for the following test:
fault codes P026354, P026954, P027254 and (or) P026654 are present

first time i had come across these code and i hadnt changed the fuel filter in nearly 3 years (nearly 40,000 mile) so i decided to change it and have a look at injector settings on comp. i noticed cylinder 1 code was reading 34.7 so i tried to reprogramme it and it wouldnt except code. now ive replaced all 4 injectors with remanufactured parts and it is now reading 32 and wont change.

ive tested wiring harness with multimeter and everything seems ok. ive also plugged wires for injector on cylinder 1 into injector on cylinder 2 and tried recoding but its still stuck on 32?!?! PLEASE HELP ME, could it be my ECU?
 

Users who are viewing this thread

Back
Top Bottom