Need some help with radio on new S-Class

Scorched Soul

New Member
Joined
Jul 26, 2003
Messages
8
Location
London
Car
MB 2000 S320L
Hi all,

Im glad i found his forum, finally somewhere where i can get some help!

I have just bought a v-reg S320L, and i is a great car, except I am having some problems with the radio.

Whenever i turn off the car and lock it, the radio turns itself on!
It turns itself on about 15-25 secs after i lock the car. It does it all the time, and the only way to get around it is to have the radio on while i turn off the car. If the radio is turned off when i switch off the engine and remove the key, then the radio turns itself on.

Is his some kind of setting, or malfunction? The manuals are no help at all.
BTW, I think it is the Audio 10 system, with cd and cassette (standard i think).

If anyone needs anymore details, let me know.

I hope someone can help, preferably before my battery runs down! :eek:

Thanks.

regards,
Bob.
 

Maff

MB Enthusiast
Joined
Jun 4, 2002
Messages
2,485
Location
Henley-on-Thames
Hi Bob,

It is a fault for certain. If i remember correctly the radio should stay on (if it was on) until you remove the key from the socket (even with the ignition off). When you lock it with the radio on the radio should switch off automaticaly after 25mins.

Maybe a trip to the dealer for them to scratch their heads over.

Cheers, Matt.
 
OP
OP
S

Scorched Soul

New Member
Joined
Jul 26, 2003
Messages
8
Location
London
Car
MB 2000 S320L
Thanx for the reply Maff,

The radio DOES stay on until i remove the key from the socket, so i don't think that is malfunctioning.

I have two specific problems with it, but both could possibly be settings.

The major one is the one i mentioned above. The radio will turn on after i lock the car, but only if it was switched off while the engine was running. If the radio was on before the car was switched off and key removed, then the radio will not turn itself on.

Don't if that made any sense!

Second problem is that radio turns itself on after i unlock the car, after about 15-20secs.

It seems to me that the radio has some sort of auto setting switched on.

Can anyone shed some light?

Thanks.

regards,
Bob.
 

Users who are viewing this thread

Top Bottom