no glow plug light

Discussion in 'Engine' started by c250td estate, Apr 24, 2014.

  1. c250td estate

    c250td estate New Member

    Messages:
    7
    Joined:
    Apr 24, 2014
    Car:
    Merc w202 c250 estate
    Hi All,

    newbe here, hope ive posted this in right section.

    Recently got a w202 c250 td estate, goes very well, and happy until the other day. The alarm went off in the night, even though had a new battery, unlocked it, then locked it, all ok rest of the night.

    Go to start the following morning the glow plug didnt come on until after 3rd attempt at tuning the key, light goes out and started on the button.

    went out in it, low and be hold same problem, but didn't light didnt come on unitl what semmed the 30th attempt and then the TC warning triangle came on but still started no problem.

    Drove home, parked it up, glow plug light wont come on at all, and therefore cant even crank the engine, but air con fans do come on.

    Have replaced the glow plug relay, as that looked at fault, but still no joy.

    Am thinking either glow plugs, but apparently if theyre at fault the light comes on and stays on after starting, or ignition switch/barrell.

    Any help greatly received.

    Thanks in advance.
     
  2. wongl

    wongl Hardcore MB Enthusiast

    Messages:
    739
    Joined:
    May 29, 2005
    Location:
    Hong Kong
    Car:
    A180CDI x3, C300h
    I have never experienced a glow-plug fault that stopped the engine from cranking. Sounds like you may have another fault which the glow plug is masking. Best to get a Star Diagnostic on to see what faults are being logged on your car.
     
  3. OP
    OP
    c250td estate

    c250td estate New Member

    Messages:
    7
    Joined:
    Apr 24, 2014
    Car:
    Merc w202 c250 estate
    Thanks Wongl.

    A local garage tried their launch machine and no luck.

    Booked in tomorrow at another garage, will up date you.

    Thanks for reply.
     
  4. grumpyoldgit

    grumpyoldgit Hardcore MB Enthusiast

    Messages:
    2,604
    Joined:
    May 7, 2012
    Location:
    Stourbridge
    Car:
    C270CDI Avantgarde SE
    As wong said, a STAR diagnostics is best. (Mercedes own).

    It should start without the glowplugs preheating in this mild weather.
     
  5. OP
    OP
    c250td estate

    c250td estate New Member

    Messages:
    7
    Joined:
    Apr 24, 2014
    Car:
    Merc w202 c250 estate
    thanks grumpyold git. i am trying to do a bit more investigative work, as im been suggested other faults like crank sensor ...... as it wont crank.

    But yes failing that Garage does have Star, so we'll wait and see.

    Thanks
     
  6. SilverSaloon

    SilverSaloon MB Club Veteran

    Messages:
    7,759
    Joined:
    Mar 16, 2004
    Car:
    1994 W124 E300D Estate, 1985 R107 280SL
    the car should crank even with glowplug relay and therefore glowplugs disconnected (done this many times on mine to pull fuel through after replacing pipes/filter without wasting battery preheating)

    i suspect its something else.

    if a glowplug is dead then you can test it via multimeter on the plug that goes into the relay. if one is dead, the light will not light up when you put ignition to II..... the light will then also come on when you start the car for about a minuite and then go off again.
     
  7. guydewdney

    guydewdney Hardcore MB Enthusiast

    Messages:
    2,903
    Joined:
    Feb 14, 2004
    Location:
    Porlock, Zomerzet
    Car:
    906 Sprinter 313cdi
    Dodgy ign switch, refusing to give DAS? Das is drive authorisation system. Mine did the same. Oddly a loose ign switch barrel also causes problems. The shiney ring around the hole needs tightening with a pair of long thin nosed pliers, or the correct merc tool....

    If it is the das, then you need all THREE parts, ign switch, steering lock, and ecu. They are useless alone. Oh and key, so four.... Lol.
     
  8. Dieselman

    Dieselman Banned

    Messages:
    34,206
    Joined:
    Jul 13, 2003
    Car:
    Peugeot 403 Convertible
    Check the engine earth strap connections.
     
    1 person likes this.
  9. OP
    OP
    c250td estate

    c250td estate New Member

    Messages:
    7
    Joined:
    Apr 24, 2014
    Car:
    Merc w202 c250 estate
    Thanks all. Have checked ignition switch wiring.

    No news as yet, hoepfully tomorrow. but i did also check earth straps too :(

    thanks for replies will post hopefully tomorrow with the outcome.
     
  10. OP
    OP
    c250td estate

    c250td estate New Member

    Messages:
    7
    Joined:
    Apr 24, 2014
    Car:
    Merc w202 c250 estate
    hi all apologies for late reply, all fixed. Corrosion on a dodgy earth strap.

    But will post, new problem now, remote locking playing up now.
     
Tags:

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.