no ignition lights at all w124 e300 d

Discussion in 'Electronics' started by mayfair, May 15, 2019.

  1. mayfair

    mayfair New Member

    Messages:
    4
    Joined:
    May 15, 2019
    Location:
    durham
    Car:
    mercedes w124 estate
    hello

    w124 1994 e300d 120,000 miles

    turned igniton and have no lights on binnacle at all

    clock works ,elec windows work but no ignition whatsoever.

    checked all fuses in box,all ok ,is there another fuse anywhere else that could be causing this?

    key turns as it should

    any suggestions (battery works windows so that is good just not ignition lights or power to starter)

    all help greatfuly recieved

    al Durham
     
  2. optimusprime

    optimusprime Hardcore MB Enthusiast

    Messages:
    2,715
    Joined:
    Dec 29, 2013
    Location:
    Kidderminster Worcestershire UK
    Car:
    Mercedes W124 260E M103
    You could check this fuse only one i know of thats not in the fuse box . Its fixed in to the rear of the binnical see picture. W124 Cluster Fuse (1) red bis.jpg
     
  3. OP
    OP
    mayfair

    mayfair New Member

    Messages:
    4
    Joined:
    May 15, 2019
    Location:
    durham
    Car:
    mercedes w124 estate
    hell optimus prime

    many thanks for reply much apreciated,

    fortunately I managed to trace fault to the ignition switch not turning at the rear of the unit

    Unfortunately i am having the usual nightmare of getting the barrel out of the metal shroud ,half a dozen angled
    bits of coat hanger later still not sliding out

    Will be trying again tomorrow ,i am sure to get there soon

    once again many thanks

    al
     
  4. OP
    OP
    mayfair

    mayfair New Member

    Messages:
    4
    Joined:
    May 15, 2019
    Location:
    durham
    Car:
    mercedes w124 estate
    was meant to say hello not hell :)

    even keyboards on the blink now:(

    al
     
  5. optimusprime

    optimusprime Hardcore MB Enthusiast

    Messages:
    2,715
    Joined:
    Dec 29, 2013
    Location:
    Kidderminster Worcestershire UK
    Car:
    Mercedes W124 260E M103
    Remove battery while you play with the switch.
     
  6. OP
    OP
    mayfair

    mayfair New Member

    Messages:
    4
    Joined:
    May 15, 2019
    Location:
    durham
    Car:
    mercedes w124 estate
    will do - managed to short the wiring at rear to prove the fault ,the engine turns etc - so definitely
    a faulty barrel or the female part of the plug at the rear

    somebody has been at it in the past and give up !as the pins dont slide in easy ,barrel seems to be off centre
    there was a new lock centre in the rear boot compartment and wood screws holding the under dash cover up as well
    as behind the facia trim.

    will get sorted - trying to resist -disc cutting metal shroud off thats cheating ,but may well happen
    , as in the past :wallbash:

    cheers al
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.