Only getting heat on the windscreen w203

Discussion in 'General Discussion' started by John_Doe, Jan 17, 2016.

  1. John_Doe

    John_Doe Hardcore MB Enthusiast

    Messages:
    224
    Joined:
    May 5, 2011
    Car:
    C32
    Not sure if this is the right place to post but couldn't find a heating section

    I'm only getting heat coming out of the windscreen vents. If I put the heater on the hottest setting and put it to clear just the windscreen it comes out nice and hot from the very top vents and the little side window ones.

    But if I switch it to any of the lower vents, like the face / feet ones I only get very slightly warm air. What the hell could this be.
     
  2. grumpyoldgit

    grumpyoldgit Hardcore MB Enthusiast

    Messages:
    2,604
    Joined:
    May 7, 2012
    Location:
    Stourbridge
    Car:
    C270CDI Avantgarde SE
    Have you tried a heater flap reset?

    W203

    To reset heater flaps and actuators

    Switch on ignition.

    Press recirculated air and defrost buttons on control panel together for longer than 5 seconds.

    The LED's in the defrost and recirculated air buttons flash alternately.

    Wait until the LED's stop flashing (approx 30 sec) system set to defrost LED on.

    Switch off ignition.

    After 40 sec re start engine.
     
  3. OP
    OP
    John_Doe

    John_Doe Hardcore MB Enthusiast

    Messages:
    224
    Joined:
    May 5, 2011
    Car:
    C32
    Actually, no. I forgot about this. Will try it tonight.

    It just seems strange. I could understand if it was only blowing at half speed but it blows on full power, just won't get hot.
     
  4. OP
    OP
    John_Doe

    John_Doe Hardcore MB Enthusiast

    Messages:
    224
    Joined:
    May 5, 2011
    Car:
    C32
    I tried the reset but the buttons just continuously flash. They never stop. I left it about five mins.

    What does that mean?
     
  5. OP
    OP
    John_Doe

    John_Doe Hardcore MB Enthusiast

    Messages:
    224
    Joined:
    May 5, 2011
    Car:
    C32
    Any ideas?
     
  6. Benzmanc

    Benzmanc Hardcore MB Enthusiast

    Messages:
    1,317
    Joined:
    May 22, 2011
    Location:
    Tameside
    Car:
    R231 SL 350 + Honda Blackbird
    Where abouts are you as someone may have a diagnostic machine nearby.
     
  7. Dave Richardson

    Dave Richardson Hardcore MB Enthusiast

    Messages:
    769
    Joined:
    Oct 14, 2007
    Location:
    Plymstock Plymouth
    Car:
    C Class 220 Evo CDI and a W176 A class 180 cdi
    Possibly the dreaded heater motor flap problem?
    Do you hear the clicking noise from behind the dash board ?
    A star check is the best way forward & if the clicking problem is there it'll identify the problem flap or flaps.
     
  8. OP
    OP
    John_Doe

    John_Doe Hardcore MB Enthusiast

    Messages:
    224
    Joined:
    May 5, 2011
    Car:
    C32
    I'm Tunbridge wells.

    No I don't get any clicking behind the dash. I don't really know how the stepper motors work but I would have thought they just move the flaps to redirect the air flow, I wouldn't have thought they had one to then control the heat separately to the flow. If that makes sense.
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.