Please what is this and whats it for/do etc....or as I suspect not doing...

rossy

Active Member
Joined
Feb 19, 2006
Messages
375
Location
Bolton, Greater Manchester
Car
Me:-CLS55 AMG & ML280 Edition Wife:-Pug 3008 GT Line Premium
Hi,
Ok just bought another Merc...ML280 Edition 2007....hope to get pro remap at some point...
anyway, Long story short the engine cover was off....but they have it and car drives fine....but what is this in the red Circle? I've googled images of the 3.0 CDI engines and I think....it maybe on upsidedown or something....as none of the engines without covers on look like this??
My thought was Cruise control as its a motor thing that if turned by hand returns back say as you'd expact a thottle body to do....but criuse works fine?

it bugging the hell out of me....one not knowing and two whats it for and could it be needed etc....looks as though a cable should be atached its clearly ment to operate something and isn't connected to out?
PLEASE HELP!
 

Attachments

  • New-1.jpg
    New-1.jpg
    338.3 KB · Views: 353
Last edited:
OP
OP
rossy

rossy

Active Member
Joined
Feb 19, 2006
Messages
375
Location
Bolton, Greater Manchester
Car
Me:-CLS55 AMG & ML280 Edition Wife:-Pug 3008 GT Line Premium
inlet swerl flap motor?
Seems to be what it is...whats it for other than swerling a flap...
 

whitenemesis

MB Club Veteran
SUPPORTER
Joined
May 7, 2007
Messages
17,646
Car
Lexus RC300h F-Sport 2019
Any part numbers on the casing?
Unusual for the loom to be tie-wrapped like that (especially touching a hot surface) and to be much longer than appears required. Makes one wonder if it's OE or aftermarket or bodge repair?
 
OP
OP
rossy

rossy

Active Member
Joined
Feb 19, 2006
Messages
375
Location
Bolton, Greater Manchester
Car
Me:-CLS55 AMG & ML280 Edition Wife:-Pug 3008 GT Line Premium
No defo think its been put on upside down....cable routed differant....doing own search..seems flaps in the inlet jam up....causing issues with smoke/emmisions etc....wating to hear back from the garage.....so far they only have a deposit...
 

Smart320

MB Enthusiast
SUPPORTER
Joined
Feb 10, 2017
Messages
2,572
Location
Barrybados
Car
Mini Cooper, Toyota RAV4 3dr , SLK55amg ( gone )
Very sensible move, I would have done the same
 

Larkone

Active Member
SUPPORTER
Joined
Jun 13, 2016
Messages
862
Location
Essex
Car
2008 CLS 320 CDI facelift
Not got one on my OM642 (2008). Looks like it has recently been replaced by the new loom going to it. Its not the swirl flap motor as these are down in the V under near the fuel filter and turbo inlet. If they play up you can fix them (switch them off) with a 50p resistor.
 
OP
OP
rossy

rossy

Active Member
Joined
Feb 19, 2006
Messages
375
Location
Bolton, Greater Manchester
Car
Me:-CLS55 AMG & ML280 Edition Wife:-Pug 3008 GT Line Premium
They just knocked another £100 off so its back on.....lol so if not swirl flap what is it...come on someone must know...DONT FORGET ITS NOT IN THE POSSITION IT SHOULD BE i think its upsidedown...so maybe this?
 

Attachments

  • New-1.jpg
    New-1.jpg
    338.3 KB · Views: 133
  • Mercedes-Benz_OM642.jpg
    Mercedes-Benz_OM642.jpg
    427 KB · Views: 136
OP
OP
rossy

rossy

Active Member
Joined
Feb 19, 2006
Messages
375
Location
Bolton, Greater Manchester
Car
Me:-CLS55 AMG & ML280 Edition Wife:-Pug 3008 GT Line Premium
DEFO LOOKS EXACTLY LIKE THIS! and this is a swirl flap motor!!
 

Attachments

  • swirl.jpg
    swirl.jpg
    246.9 KB · Views: 43

Mattns

Active Member
Joined
Jan 7, 2017
Messages
172
Car
2005 S320 CDI
if you are brave you could try disconnect and see what changes?
 
OP
OP
rossy

rossy

Active Member
Joined
Feb 19, 2006
Messages
375
Location
Bolton, Greater Manchester
Car
Me:-CLS55 AMG & ML280 Edition Wife:-Pug 3008 GT Line Premium
well as its not connected to anything (only plugged in) I gues the only thing that could change is a certain light appearing on the dash....having spoken to a mate at a diesel place he says quite common issue and can be coded out...guess a bit like EGR valves etc.....but I'll no more on Thrsday coz thats when it should be delivered....as wife said...my labour is free and there is not much I can't fix with help from forums like this and videos etc....
I've built Kit cars...restored classics.....(now at my age driven quite a few too) so £3700 for a 57 plate ML280 Edition is not bad in my book, new Battery new disc and pads all round...machin tyres clearly looked after....tho now its sold as seen....no warranty that just same as a private sale anyway!
 
Last edited:

m80

MB Enthusiast
Joined
Apr 26, 2015
Messages
2,595
Location
Derbyshire, High Peak
Car
Vito 115 Lwb Dualiner.
Your post 13 is definitely an 'inlet port shut off motor', t'other images aren't so clear but looks to be the same.

In situ it would be sited down in the V, as said. Common failing is oil leaking from the turbo spigot orange seal onto it, that kills 'em eventually.
The plastic inlet flaps can break up into the inlets also, or as you say the whole connection rod set of the 2 x 3 might seize, but less common to my mind.

If / when the motor siezes the motor can be unplugged and a resistor linked across to cheat the ECU. You could do that with this to clean up the very obvious repositioned motor. Then the wiring might be insulated and tucked back down toward the V.

You might want to check status / condition of the swirl flaps and mechanism for peace of mind.

Oh, if you just unplug you will get a fault up, not sure if that'll initiate limp as the usual when the motor goes u/s is to take a common fuse with it that supplies other kit.
 

Larkone

Active Member
SUPPORTER
Joined
Jun 13, 2016
Messages
862
Location
Essex
Car
2008 CLS 320 CDI facelift
Looks like they have connected a swirl flap motor because the original has failed and they wanted to get around the MIL codes without the work to strip down enough to get at the swirl flap motor and linkages. It just isn't connected to the swirl flaps. Would have been easier to just use a resistor (4.7K) across the the two middle terminals of the plug to fool the ECU. What they have done works from the point of view of no codes but not very elegant. Gives you a good point for arguing the price down.

If you do buy it, put the resistor in and sell the swirl flap motor. They run perfectly well without their swirl flaps and fixing them is very labour intensive and potentially costly if you need to buy new linkages from MB (I think new inlet manifolds). There are companies (X8R) that make linkage repair kits.
 
OP
OP
rossy

rossy

Active Member
Joined
Feb 19, 2006
Messages
375
Location
Bolton, Greater Manchester
Car
Me:-CLS55 AMG & ML280 Edition Wife:-Pug 3008 GT Line Premium
Looks like they have connected a swirl flap motor because the original has failed and they wanted to get around the MIL codes without the work to strip down enough to get at the swirl flap motor and linkages. It just isn't connected to the swirl flaps. Would have been easier to just use a resistor (4.7K) across the the two middle terminals of the plug to fool the ECU. What they have done works from the point of view of no codes but not very elegant. Gives you a good point for arguing the price down.

If you do buy it, put the resistor in and sell the swirl flap motor. They run perfectly well without their swirl flaps and fixing them is very labour intensive and potentially costly if you need to buy new linkages from MB (I think new inlet manifolds). There are companies (X8R) that make linkage repair kits.
This is exactly what I've done....(4.7k) so flaps guess wedged open as there is no motor in the correct place....anyway engine cover is now back on....car drive perfect as is....as you say not needed as I have done a lot a reading up on them....in fact some Model do not have them at all!
Anyhow....cracking on with other jobs.....painted the wheels today Sparkle Black....not that they needed painting they where close to mint....which made the Job easier...just think black car....suit black ot dark gray wheels and had plently of paint left over from the CLS.....
Managed to get one of them Android Nav units that look like the original....so lot easier to have reverse Cam etc....also will have Dab TV.....:) nearly done....will post before and afters....:)
 
OP
OP
rossy

rossy

Active Member
Joined
Feb 19, 2006
Messages
375
Location
Bolton, Greater Manchester
Car
Me:-CLS55 AMG & ML280 Edition Wife:-Pug 3008 GT Line Premium
OK I've research this but not found a exact answer, ML drives sweet no smoke at all driving under load up hills or if you stop at lights etc....
However, if you park up with engine running for say 15-20mins it smokes its nuts off....more if you rev it...but then drive it and it clears and is fine again and only happens if you stop for same amount of time....so would not normaly but noticed unless say in a traffic Jam or in my case...sat waiting for the Kids to come out of school watch TV in it with engine on so not to flatten battery....
Obviously bare in mind the above....i.e. no swirl flap motor.....and not sure of the possition of the flaps as was done before I got it....but like I say drives spot on!!
Smoke smells....done an oil change and its the same just in case it had too much oil in....I've perposly refilled to under the full mark!
Help! Should a great car bar this.....
 

Users who are viewing this thread

Top Bottom