Pre facelift E63 AMG 7g+ autobox issue.

pattiodors

Member
Joined
Oct 19, 2015
Messages
52
Location
Dereham Norfolk
Car
2003 W203 C32 AMG Estate. Hyundai IX35 2.0 4wd
Glad it's all ok, I wouldn't trust any garage or builder until I got second opinion or
knew the mechanic was working on my car was honest and knew what he was talking about. A garage is only as good as the mechanics that work there. That's why I try to do all my own repairs as far as possible.
 

MrGreedy

MB Enthusiast
Joined
Jan 13, 2020
Messages
1,050
Location
Midlands
Car
w212 E350 CDI 125th Anniversary Edition
So I'll update this thread with the outcome of what the actual problem was....yes it's now fixed!

Ready for this......
Throttle body needed re adapting/throttle actuation :rolleyes:
The rev flair wasn't clutch slip at all but the throttle body chucking a wobbler.

I had the gearbox oil dropped again today, just to make sure everything was ok, and as I/we suspected there was no evidence of water in the oil.

So that's it, the car is back to normal and driving smoother than ever.

I'd like to thank all who gave their input.
Hi Boristheblade,

thank you very much for updating.

I've read though the thread and got a bit confused, as it is quite long.

Could you please remind me/summarise:

- did you get fault codes scanned, who by and were any found? and,

- who found the throttle body issue and how did they find it?


Really glad you got it sorted without spending £3,000+!
 

Users who are viewing this thread

Top Bottom