Problem Starting from cold

rhinoman

New Member
Joined
Dec 2, 2012
Messages
1
My 2008 e320 cdi Sport has developed a starting problem. Only ever from cold. It started turning over more than it used to and then once warm is fine. Today however it didn't start after three attempts I left it for an hour, it then started at the second attempt. It has 113,000 miles on clock, has had 7 MB dealer services in 4 years from new. Any ideas , it kicks out a load of White smoke too from cold. On the road it performs as always, pulls great and never misses a beat. I understand the EGR valve may need replacing ???? Any suggestions gratefully received, not sure how much this will cost to replace ?!?!?
 

ALNoteman

Member
Joined
Nov 13, 2012
Messages
56
Location
Markfield = J22 of M1 Leicestershire.
Car
2003 Mercedes C-270 CDI Estate + Iveco Globetrotter RV 6-litre.
Hi,
I have same problem with my C270 CDI. To try to cure it I have so far changed the flexible fule pipes on top of motor in case leaking seals were causing air to enter pipes when fuel in tank gets cold causing gas to condense and shrink causing airlock in fuel pipe. That helped but on the night it was minus 3 the next morning it would not start. I have been told to have glow plugs checked but these are fine in warmer weather. I even tried blowing a hot air gun into air intake and this did help when it was not below 0 degrees C. I have since discovered diesel on the tarmac where I park so there is a fuel line leak and this will cause air to be sucked into the fuel supply line as fuel leaks out, this must be causing a big air lock and the fuel pump can't seem to cope with it.
Next job it to remove the tray below the car to see where the leak is and hope to cure it. I'm also told the fuel pump can have very small leaks in its seals so check that for signs of diesel on the outside of it. If you find what is causing your problems please let me know.

Al.
 

Sriandy

Member
Joined
Dec 3, 2012
Messages
35
Car
Vectra
What make are the glow plugs? We've had this at work before on the 320s. If they are not genuine behr plugs they cause issues. The White smoke is unburnt diesel.
 

WG M-B

Auhorised Forum Sponsor
SUPPORTER
Joined
May 26, 2011
Messages
1,897
Location
N/W london
Car
C63 Wagon in black
As above wrong glow plugs or faulty glow control unit
 

Users who are viewing this thread

Top Bottom