Problem with DAB in W204 - Audio 20

Discussion in 'Electronics' started by texasjohn, Oct 22, 2011.

  1. texasjohn

    texasjohn Hardcore MB Enthusiast

    Messages:
    246
    Joined:
    Jul 13, 2009
    Location:
    Southampton
    Car:
    335i Vermillion Red
    It's all working ok, but the problem is that DAB always resets itself to Kerrang as the default station each time I get into the car.

    Usually listen to Radio 2 so you can imagine this is annoying.

    Drive home, radio 2. Switch car off. Get back into car in the morning and switch on, bloody Kerrang there again! Finish work, get into car, surprise surprise it is Kerrang.

    Has anyone got any ideas how I can set the 'default' station on DAB for anything other than Kerrang?

    The manual doesn't seem to cover such a setting but is there anything in the engineering menus?

    I don't mind Rock music really but I just want the same station I was listening to (be it, BBCR2, R1, R1X or whatever) to be selected when I come back to the car.
     
  2. OP
    OP
    texasjohn

    texasjohn Hardcore MB Enthusiast

    Messages:
    246
    Joined:
    Jul 13, 2009
    Location:
    Southampton
    Car:
    335i Vermillion Red
    Anyone got any idea?
     
  3. richard

    richard Authorised Forum Sponsor Authorised Forum Sponsor

    Messages:
    6,081
    Joined:
    Jun 10, 2002
    Location:
    Berkshire, UK
    Car:
    MY04 SL55, MY18 GLC63s
    I suspect it all needs a firmware update

    Richard
     
    1 person likes this.
  4. Fuji

    Fuji Member

    Messages:
    52
    Joined:
    Aug 31, 2011
    Car:
    C250 CDI AMG ED125 Coupe
    Have you set any presets? If you press and hold a number on the number pad (in my car, the number pad is in the dash, to the right of the CD slot), it will store the station against that preset.

    Even if this doesn't fix the problem, it'll make it quicker to get to a station you DO want to listen to!
     
    1 person likes this.
  5. OP
    OP
    texasjohn

    texasjohn Hardcore MB Enthusiast

    Messages:
    246
    Joined:
    Jul 13, 2009
    Location:
    Southampton
    Car:
    335i Vermillion Red
    Yes, I have set all the presets and, to clarify, Kerrang is not one of them.


    Many thanks for the replies gents
     
  6. craig1912

    craig1912 Hardcore MB Enthusiast

    Messages:
    165
    Joined:
    Jun 20, 2011
    Car:
    C250 Sport
    Mine resets to "Gold" I 've had loads of problems in that occasionally the dab radio won't change volume and at the same time my ipod locks up. Dealer has had it 4 times and supposidly changed the head unit twice.

    forgot to mention that it didn'tbusedvto do the gold thing but it started after a head unit change
     
  7. IanStarby

    IanStarby New Member

    Messages:
    2
    Joined:
    Apr 24, 2013
    Car:
    C Class Coupe
    Did you ever sort your DAB station issue texasjohn. I'm having exactly the same issue. Radio 5 every morning and evening! Thanks
     
  8. SmartMAC

    SmartMAC Hardcore MB Enthusiast

    Messages:
    389
    Joined:
    Feb 18, 2012
    Location:
    Madrid, Spain
    Car:
    C250 CDI Sport Coupe AMG
    Mine used to freeze on the volume and revert to radio 5 every time. It had a software update a month ago and it is all fine now.

    I got it done at MB Manchester and they said it would be a software issue when I booked it in.
     
    Last edited: Apr 25, 2013
  9. craig1912

    craig1912 Hardcore MB Enthusiast

    Messages:
    165
    Joined:
    Jun 20, 2011
    Car:
    C250 Sport
    Yep had my software update a few weeks ago and one works fine
     
  10. asinrutee

    asinrutee Hardcore MB Enthusiast

    Messages:
    110
    Joined:
    Aug 23, 2012
    Location:
    The Bristol Area
    Car:
    C Class Coupe
    I cured this by going to the settings menu and resetting to factory defaults. Then when I retuned the radio it defaulted to the last station I was listening too, it has been fine now for a couple of months
     
    2 people like this.
  11. igk1

    igk1 Active Member

    Messages:
    72
    Joined:
    Dec 7, 2009
    Location:
    Essex, UK
    Car:
    W212 E220CDI Avantgarde, W166 GLE 250d Sport
    After several trouble-free months I'm now getting Absolute 00's every time :mad:
    Wouldn't mind if was Absolute 80's...
    Will try the System Reset, but when I have time to redo my phone contacts as I believe they will be lost.
     
  12. #Dan

    #Dan Hardcore MB Enthusiast

    Messages:
    114
    Joined:
    Jul 18, 2012
    Location:
    Cheshire
    Car:
    C250 AMG Sport Plus Coupe
    Thanks for this - I've had my car from brand new 10 months now without any problems,but all of a sudden this week my DAB decides that I was Radio1 to come on every time I switch on.

    Tried the reset last night and it's sorted it - cheers! :cool:
     
  13. Ditch999

    Ditch999 Member

    Messages:
    30
    Joined:
    Mar 13, 2014
    Location:
    Omagh, NI
    Car:
    B200 Sport auto W246
    I must try this too as my DAB radio will not play the station when it turns on, all you get is silence! It works if you then tune in to another station but you have to go back to what you want to listen to!
     
  14. Doug Doug

    Doug Doug New Member

    Messages:
    3
    Joined:
    Jan 22, 2016
    Car:
    C Class W204
    I have just had the Audio 20 start on my 2012 W204. I have contacted MB but Customer Service are in denial and say they don't know of it. It's just out of warranty and they won't give good will! I think that stinks.

    If I use the factory reset, does it affect the saved routes in the removable Becker Map Pilot satnav?
     
  15. richard

    richard Authorised Forum Sponsor Authorised Forum Sponsor

    Messages:
    6,081
    Joined:
    Jun 10, 2002
    Location:
    Berkshire, UK
    Car:
    MY04 SL55, MY18 GLC63s
    What do you mean by the 'Audio 20 start'.

    R
     
  16. OP
    OP
    texasjohn

    texasjohn Hardcore MB Enthusiast

    Messages:
    246
    Joined:
    Jul 13, 2009
    Location:
    Southampton
    Car:
    335i Vermillion Red
    Yes, a software update was performed and it all worked perfectly afterwards.

    Unfortunately nothing could be done about the horrible ride and clattery OM651 engine, although I left that job in late 2012 and handed the car back (company car).

    I've enjoyed my petrol Mercedes since but that C250 nearly put me off the brand for life!
     
  17. Doug Doug

    Doug Doug New Member

    Messages:
    3
    Joined:
    Jan 22, 2016
    Car:
    C Class W204
    Audio 20 and DAB

    Sorry I should have described it better. Meant to say: "I have just had my Audio 20 start to retune itself" after being switched off, as described by others.
     
  18. Doug Doug

    Doug Doug New Member

    Messages:
    3
    Joined:
    Jan 22, 2016
    Car:
    C Class W204
    Audio 20 reset

    I used the reset facility on the Audio 20 and - so far for a couple of days - eliminated the problem of the radio tuning itself to one DAB station. The pain is that you have to re-enter all the data - stored stations on all bands, 'phone information, etc. But if it works - yipee!
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.