Problem with remote locking - CL500

Discussion in 'Electronics' started by TonyWillis, Mar 13, 2017.

  1. TonyWillis

    TonyWillis New Member

    Messages:
    10
    Joined:
    Dec 29, 2016
    Car:
    mERCEDES cl500 2004
    Help please!
    have a problem that seems to have 3 mercedes indies scratching their heads. I'm sure that some of the brains in the club will know what the solution is so here goes:
    Following a flat car battery and recharge, the remote central locking wouldn't operate. if the door is opened with the mechanical key to get in, put a key in the ignition and switch on and both keys work fine - start the car no problem, central locking works using either the dashboard buttons or the buttons on both keys everything works perfectly. take the key out of the EIS and doors and boot lock/unlock normally with both keys working for about 20 seconds then nothing! Put the key back in the ignition and turn on - both keys work remotely again. On key is brand new from mercedes for £240 and both have been tested.
    It's as if the EIS goes to sleep about 20 seconds after the key is taken out - during that time they both work remotely with no problem.
    Has anyone any ideas because I'm getting desperate now and hate to take it to main dealer as they say that the keys are working and are 95% sure that it is the EIS unit and that will be around £900 to put a new one in - Ugg!!
    Thanks
    Tony 07734882082
     
  2. Dec

    Dec Hardcore MB Enthusiast

    Messages:
    4,475
    Joined:
    Jul 28, 2004
    Car:
    C180,A.
    1 person likes this.
  3. renault12ts

    renault12ts MB Club Veteran

    Messages:
    15,900
    Joined:
    Mar 5, 2009
    Car:
    2005 W215 CL500.
    Disconnect the battery. Leave it be for a while and then reconnect. You'd be surprised what effect this can have on a W215.
     
  4. BlackC55

    BlackC55 Authorised Forum Sponsor Authorised Forum Sponsor

    Messages:
    18,755
    Joined:
    Feb 8, 2007
    Location:
    Horndean, Portsmouth, Hampshire, Southsea
    Car:
    C43 AMG with a 55 engine and supercharger, E55 AMG, S500, etc
    Its very likely to be the EIS. I have had this before.
     
    1 person likes this.
  5. OP
    OP
    TonyWillis

    TonyWillis New Member

    Messages:
    10
    Joined:
    Dec 29, 2016
    Car:
    mERCEDES cl500 2004
    The siren has been disconnected but not sure if it was ever working. When I unlock the door manually the indicators flash until I insert the key in the ignition though.The last garage tried it with a spare siren and it worked fine. Would the siren being disconnected or not working stop the remote door locking working?
    Thanks
    Tony
     
  6. OP
    OP
    TonyWillis

    TonyWillis New Member

    Messages:
    10
    Joined:
    Dec 29, 2016
    Car:
    mERCEDES cl500 2004
    thanks BlackC55.
    I'm sure you are probably right that it is the EIS - I just havent seen this door remote problem listed as an EIS fault. Usually it seems to be that the key won't turn or start the car. Is it worth sending the EIS for repair or is it best to replace?
    What services do you do down at Horndean and if I bring the car to you is it a day job?
     
  7. Dec

    Dec Hardcore MB Enthusiast

    Messages:
    4,475
    Joined:
    Jul 28, 2004
    Car:
    C180,A.
    Unlocking the door with a mechanical key blade wouldn’t have any effect on the cars electric , however, opening the door of a car that was previously locked with a remote would, as the alarm would be armed, the fact the indicators flash, and only stop flashing when you insert the key into the ignition implies that you have just triggered an alarm that doesn’t have a working siren, you sure the alarm siren is indeed disconnected.

    Dec
     
    Last edited: Mar 13, 2017
  8. OP
    OP
    TonyWillis

    TonyWillis New Member

    Messages:
    10
    Joined:
    Dec 29, 2016
    Car:
    mERCEDES cl500 2004
    Dec - yes the alarm is definitely disconnected but wasn't working anyway. The garage disconnected it so there was no chance of it going off in the night!
     
  9. BlackC55

    BlackC55 Authorised Forum Sponsor Authorised Forum Sponsor

    Messages:
    18,755
    Joined:
    Feb 8, 2007
    Location:
    Horndean, Portsmouth, Hampshire, Southsea
    Car:
    C43 AMG with a 55 engine and supercharger, E55 AMG, S500, etc
    Can you give us a call? 02392570123
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.