r129 boot light problem ?

jasmine

Active Member
Joined
Nov 7, 2020
Messages
109
Location
Gloucester
Car
sl500 r129
hi, quick question regarding the power feed to the boot light on a 97 r129 . should there be a live on either side of the bulb when light is off or is it operated as an earth switch ? i have a drain on the battery and slowly going through the options . thanks
 

BTB 500

MB Club Veteran
SUPPORTER
Joined
Aug 7, 2005
Messages
20,229
Location
Shropshire
Car
R129 SL500, W639 Vito 120, S205 C300
I doubt it would be an earth switch, but you know you can turn the light off while the boot is open?
 
OP
OP
J

jasmine

Active Member
Joined
Nov 7, 2020
Messages
109
Location
Gloucester
Car
sl500 r129
hi, yes . looks like previous owner had problems with the light . bit of insulation tape on the bulb feed wires , will have to dig deeper , have previously removed bulb to see if drain stops but it didnt change anything thanks
 

Ted

MB Enthusiast
Joined
Feb 26, 2004
Messages
6,306
Location
Bourton on Dunsmore
Car
Lexus RC300h F-Sport, Yamaha XVS 1100, Jeep Renegade
Put you phone on video record and shut ot in the boot 👍🏻👍🏻👍🏻
 
OP
OP
J

jasmine

Active Member
Joined
Nov 7, 2020
Messages
109
Location
Gloucester
Car
sl500 r129
tried that to no avail :-( light was off. read lots of posts on boot light problems so thought i would have a dig about. Just stripped the tape off the wires and looks like they have been pieced out for some reason , but saying that nothing obvious shorting out . ive removed the bulb now and disconnected the plug to the switch . fingers crossed
 
  • Like
Reactions: Ted
OP
OP
J

jasmine

Active Member
Joined
Nov 7, 2020
Messages
109
Location
Gloucester
Car
sl500 r129
cant say exactly but it was tested and well within the parameters . had two new batteries and after 3 days window memory fails , have unplugged every fuse all plugs under seats and still got the problem, having read lots of threads the most common fault seems to be the boot light . have had quite a few sl's over the years and they all seem to have a few quirks but this one is becoming a pain )
 

BTB 500

MB Club Veteran
SUPPORTER
Joined
Aug 7, 2005
Messages
20,229
Location
Shropshire
Car
R129 SL500, W639 Vito 120, S205 C300
If the drain current isn't excessive and you have a new battery ... are you sure it's charging properly? What do you mean by window memory (the one-shot function?)? What other symptoms do you have ... are you measuring low voltage at the battery? To flatten a 100 Ah battery in 3 days you'd be looking for something that's pulling around 17 watts, which is pretty significant.
 
  • Like
Reactions: Ted
OP
OP
J

jasmine

Active Member
Joined
Nov 7, 2020
Messages
109
Location
Gloucester
Car
sl500 r129
the battery doesn't flatten in three days but drops to about 11v this makes the windows drop a third on opening the doors due to the voltage sensitive nature of these cars . alternator has been checked and charging as it should . as i said previously , i have unplugged everything i can get to including aerial , phone system , and stereo , running out of ideas now (
 

BTB 500

MB Club Veteran
SUPPORTER
Joined
Aug 7, 2005
Messages
20,229
Location
Shropshire
Car
R129 SL500, W639 Vito 120, S205 C300
the battery doesn't flatten in three days but drops to about 11v

11V is dead - a 12V lead/acid battery is deemed to be fully discharged at 11.9V. Fully charged you should have around 12.7V.
 
OP
OP
J

jasmine

Active Member
Joined
Nov 7, 2020
Messages
109
Location
Gloucester
Car
sl500 r129
0 every day is a school day . i know this subject has a million reasons but thanks for your input
 
OP
OP
J

jasmine

Active Member
Joined
Nov 7, 2020
Messages
109
Location
Gloucester
Car
sl500 r129
also, if i disconnect the negative terminal on the battery the discharge still happens ???
 

BTB 500

MB Club Veteran
SUPPORTER
Joined
Aug 7, 2005
Messages
20,229
Location
Shropshire
Car
R129 SL500, W639 Vito 120, S205 C300
also, if i disconnect the negative terminal on the battery the discharge still happens ???

Both terminals must be connected for any current to flow. If the battery voltage drops from 12.7V (resting voltage) over time with one terminal disconnected then it is self-discharging (shorting) internally and has probably had it.
 
OP
OP
J

jasmine

Active Member
Joined
Nov 7, 2020
Messages
109
Location
Gloucester
Car
sl500 r129
yes that was my thought but the car has had the original battery tested and was good but i bought another one just in case plus a known good one in the lock up and the same happened . im defo not an expert in auto electrics but aware that there has to be a full circuit to get a flow im baffled
 
OP
OP
J

jasmine

Active Member
Joined
Nov 7, 2020
Messages
109
Location
Gloucester
Car
sl500 r129
afternoon , still trying to trace battery drain / window memory fault. have had the battery on trickle charge for about five days battery was charged fully then charger left on trickle , windows were reset and worked as they should , just had look today and battery showing 12.4 v opened door and window dropped a third , reset it again and all ok. any ideas what part of the window electrics could be draining or loosing power ? thanks
 

slimall

New Member
Joined
Apr 27, 2014
Messages
10
Car
r129
the battery doesn't flatten in three days but drops to about 11v this makes the windows drop a third on opening the doors due to the voltage sensitive nature of these cars . alternator has been checked and charging as it should . as i said previously , i have unplugged everything i can get to including aerial , phone system , and stereo , running out of ideas now (
 

slimall

New Member
Joined
Apr 27, 2014
Messages
10
Car
r129
Hi I read one of you previous post regarding the window opening about a third down when you open the door did you ever find the cause of this Thanks
 
OP
OP
J

jasmine

Active Member
Joined
Nov 7, 2020
Messages
109
Location
Gloucester
Car
sl500 r129
Hi I read one of you previous post regarding the window opening about a third down when you open the door did you ever find the cause of this Thanks
hi, not found the fault as yet , prob going to get it plugged in some time in the near future . will post the findings
 

Users who are viewing this thread

Top Bottom