R129 Panny leaks a little

Indiepath

Active Member
Joined
May 30, 2008
Messages
76
Location
Poole, Dorset. UK
Car
SL500 De-Badged
Near-side where the front piller meets the roof there seems to be a bad fit and small amounts of water leak through. What's the best way to seal it?

This picture shows the point of leakage (albiet on the wrong side).
 

BTB 500

MB Club Veteran
SUPPORTER
Joined
Aug 7, 2005
Messages
19,077
Location
Berkshire
Car
R129 SL500, W639 Vito 120, S203 C230
I seem to remember there's actually a 'fitting procedure' (in WIS?) for the panoramic roof ... i.e. it's not always a simple replacement for the standard hard top. Various checks and adjustments, and (I think) in some cases different seals are required.

If the roof isn't original to the car these steps might have been skipped. The other possibility is that the roof has been damaged (twisted slightly?) at some point, while off the car. Or the seals on the top of the pillars are perished/damaged.
 
OP
OP
I

Indiepath

Active Member
Joined
May 30, 2008
Messages
76
Location
Poole, Dorset. UK
Car
SL500 De-Badged
The roof was purchased as an option from new. I'm quite sure it is a seal problem and would like to know the best way of dealing with it without getting new seals :) Maybe I should just get a lump of clear mastic and remove that when the sun shines again (in a couple of years).

EDIT: Or put the cover back on :D
 

BTB 500

MB Club Veteran
SUPPORTER
Joined
Aug 7, 2005
Messages
19,077
Location
Berkshire
Car
R129 SL500, W639 Vito 120, S203 C230
Do the seals look OK (not perished / split / cracked / etc.)?
 

ant500sl

Member
Joined
Sep 19, 2007
Messages
48
A quick smear of vaseline on the seal sorted mine out.

Still not leaking after 5 years.
 

BTB 500

MB Club Veteran
SUPPORTER
Joined
Aug 7, 2005
Messages
19,077
Location
Berkshire
Car
R129 SL500, W639 Vito 120, S203 C230
Does it leak there when the soft top is up?
 
OP
OP
I

Indiepath

Active Member
Joined
May 30, 2008
Messages
76
Location
Poole, Dorset. UK
Car
SL500 De-Badged
Nope, only the hard top
 

BTB 500

MB Club Veteran
SUPPORTER
Joined
Aug 7, 2005
Messages
19,077
Location
Berkshire
Car
R129 SL500, W639 Vito 120, S203 C230
So the seal itself must be OK. I'd be suspecting a distorted or incorrectly adjusted roof then.
 

Mark300SL

1962-2010. Gone, but not forgotten.
Joined
Jul 21, 2002
Messages
1,641
So the seal itself must be OK. I'd be suspecting a distorted or incorrectly adjusted roof then.
Same as mine

hard top has a very slight leak from the passengers screen join - soft top is fine
I was going to set up the hardtop when I fit it in a coupe of weeks time
 
OP
OP
I

Indiepath

Active Member
Joined
May 30, 2008
Messages
76
Location
Poole, Dorset. UK
Car
SL500 De-Badged
What do you guys mean by "adjusted" and "setup"? Am I to assume I can't just put the thing on?
 

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

Top Bottom