R129 roof ... Fault finding

Discussion in 'Bodywork' started by Watchcame430, Apr 20, 2014.

  1. Watchcame430

    Watchcame430 Hardcore MB Enthusiast

    Messages:
    1,949
    Joined:
    May 20, 2012
    Car:
    1994 SL500 and 2003 Designo S500
    Hi all,

    Last weekend I popped out and put the roof down.
    On returning home I pushed the button to put the roof up and nothing. (It had been working the 3 weeks I have owned the car faultless

    I don't think I can hear anything when push forward to bring the hood up.

    Pushing back does make a noise.

    I had to put the roof up manually. Not an easy job... The rear passenger side was particularly hard .. It really strained to lock with the tool.

    Question one is .... Is there a renowned R129 roof expert in the South?

    Secondly ... What would people suggest is the best way to fault find?

    So far I have oiled everything and also ordered new hydraulic fluid.

    What would be the most logical way to approach? Would like to sort myself if possible but not sure where to start. Also the web has lots of tips and videos but not a suggested way of approaching/fault finding that I can find.

    Cheers
     
  2. IanA2

    IanA2 Hardcore MB Enthusiast

    Messages:
    4,533
    Joined:
    Sep 17, 2003
    Location:
    East Mids
    Car:
    SL60 AMG, GES300, Lexus GS 430
    Probably a silly question....but do you have the engine running when you try to raise the roof?
     
  3. OP
    OP
    Watchcame430

    Watchcame430 Hardcore MB Enthusiast

    Messages:
    1,949
    Joined:
    May 20, 2012
    Car:
    1994 SL500 and 2003 Designo S500
    Please ask anything ... I am still learning and had tried it while engine running but also switched off. No question ever stupid when it comes to me! :)

    Funnily enough up to last week end I had put it down with the engine off and it was the first time I had put it down with the engine on.

    Wouldn't come up with engine off or on.

    It was also the first time I had stopped it going down before the windows came up as part of the cycle if that makes sense.

    Could either of these two things made a difference?
     
  4. IanA2

    IanA2 Hardcore MB Enthusiast

    Messages:
    4,533
    Joined:
    Sep 17, 2003
    Location:
    East Mids
    Car:
    SL60 AMG, GES300, Lexus GS 430
    Ah...do a search on that....I think Jay posted something about that some time ago.

    I always raise/lower with engine running.
     
  5. OP
    OP
    Watchcame430

    Watchcame430 Hardcore MB Enthusiast

    Messages:
    1,949
    Joined:
    May 20, 2012
    Car:
    1994 SL500 and 2003 Designo S500
  6. IanA2

    IanA2 Hardcore MB Enthusiast

    Messages:
    4,533
    Joined:
    Sep 17, 2003
    Location:
    East Mids
    Car:
    SL60 AMG, GES300, Lexus GS 430
    Yup....that's the one I had in mind......not raining here:D
     
  7. OP
    OP
    Watchcame430

    Watchcame430 Hardcore MB Enthusiast

    Messages:
    1,949
    Joined:
    May 20, 2012
    Car:
    1994 SL500 and 2003 Designo S500

    It was strange ... Was looking out the window and said it might thunder ... 15 seconds later it did!

    Just hoping its dry tomorrow. Been deep cleaning the boot carpets so want to refit them too.
     
  8. rorf

    rorf Hardcore MB Enthusiast

    Messages:
    424
    Joined:
    Jul 23, 2011
    Location:
    Cape Town, South Africa
    Car:
    2000 SL320 v6, 2001 CLK320
    Make sure the windows are open (fully down) when you try and close the roof; better to have the engine running too. Also ensure in Park.
     
  9. edgersoldchap

    edgersoldchap Hardcore MB Enthusiast

    Messages:
    145
    Joined:
    May 11, 2007
    Location:
    Cheshire, UK
    Car:
    S211 E320 CDI, Jaguar XKR 5.0 Speed Pack
    Have you synchronised the windows? Open both fully, then close them with the switch not fully depressed - when the windows are fully closed, push the switches fully down and hold for 3 seconds. You may hear a soft click. Then try the roof again. If the windows and the roof motor are not in sync the system does not know where it is in the roof opening/closing cycle and nothing happens. Mine often gets out of sync for some reason. If it doesn't work first time - do it again.
     
    1 person likes this.
  10. OP
    OP
    Watchcame430

    Watchcame430 Hardcore MB Enthusiast

    Messages:
    1,949
    Joined:
    May 20, 2012
    Car:
    1994 SL500 and 2003 Designo S500

    Pretty sure I did do this. Was trying all combinations to be honest !
     
  11. OP
    OP
    Watchcame430

    Watchcame430 Hardcore MB Enthusiast

    Messages:
    1,949
    Joined:
    May 20, 2012
    Car:
    1994 SL500 and 2003 Designo S500
    Thanks .. Great tip ... Will try that first!
     
  12. DSB SL AMG

    DSB SL AMG Hardcore MB Enthusiast

    Messages:
    1,599
    Joined:
    Jan 28, 2010
    Location:
    Cheshire
    Car:
    300SL (R129 1992 pre-facelift), Volvo V70 SE D5 Auto Geartronic
    The R129 roof system is very sensitive to battery charge, hence why always best operating with car running...I always ensure my battery is fully charged before I re-fit for summer use...
     
    1 person likes this.
  13. OP
    OP
    Watchcame430

    Watchcame430 Hardcore MB Enthusiast

    Messages:
    1,949
    Joined:
    May 20, 2012
    Car:
    1994 SL500 and 2003 Designo S500
    I think I had read to use it with the engine off (or someone maybe told me) ... I did think it odd as it must put a big strain on it?

    Hopefully it will not be too problematic to sort but happy to spend some time on it. I like getting to know the car.
     
  14. Mercedes man

    Mercedes man Hardcore MB Enthusiast

    Messages:
    190
    Joined:
    Dec 23, 2012
    Location:
    Gravesend
    Car:
    Mercedes c43 amg
    R129 roof not working

    Hi in the boot is a fuse box at the bottem is a large fuse which is screwed in they corrod around screw and don't work check this first stew
     
    1 person likes this.
  15. OP
    OP
    Watchcame430

    Watchcame430 Hardcore MB Enthusiast

    Messages:
    1,949
    Joined:
    May 20, 2012
    Car:
    1994 SL500 and 2003 Designo S500
    Thanks will have a good look at them in case.
    Cheers!
     
    1 person likes this.
  16. IanA2

    IanA2 Hardcore MB Enthusiast

    Messages:
    4,533
    Joined:
    Sep 17, 2003
    Location:
    East Mids
    Car:
    SL60 AMG, GES300, Lexus GS 430
    Working yet?
     
    1 person likes this.
  17. edgersoldchap

    edgersoldchap Hardcore MB Enthusiast

    Messages:
    145
    Joined:
    May 11, 2007
    Location:
    Cheshire, UK
    Car:
    S211 E320 CDI, Jaguar XKR 5.0 Speed Pack
    Check fuses 9 and 4 in the boot fuse box. When my roof didn't operate and the switch inside the car was illuminated to indicate a fault, I checked these 2 fuses and although they were not blown, just moving them to ensure perfect contact made it work OK.
     
    1 person likes this.
  18. OP
    OP
    Watchcame430

    Watchcame430 Hardcore MB Enthusiast

    Messages:
    1,949
    Joined:
    May 20, 2012
    Car:
    1994 SL500 and 2003 Designo S500

    Thanks, did this and did get the click. It didnt work though sadly.
    I am sure was worth doing.
     
  19. OP
    OP
    Watchcame430

    Watchcame430 Hardcore MB Enthusiast

    Messages:
    1,949
    Joined:
    May 20, 2012
    Car:
    1994 SL500 and 2003 Designo S500

    Done ... My button just flashed when i push it forward or back but no luck. Will not go down now.
     
  20. OP
    OP
    Watchcame430

    Watchcame430 Hardcore MB Enthusiast

    Messages:
    1,949
    Joined:
    May 20, 2012
    Car:
    1994 SL500 and 2003 Designo S500

    Sadly not ... Reading through at the moment in the car with the ipad trying everything.... No luck so far.
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.