R230 SL - Ignition Switch Problem?

Discussion in 'Electronics' started by adamcot, Feb 5, 2017.

  1. adamcot

    adamcot New Member

    Messages:
    2
    Joined:
    Feb 5, 2017
    Car:
    Jaguar XE Alfa GTV
    Hi All,

    Firstly, this is my first post, I've had a search and can't find anything definitive... and I'm not sure if I'm posting in the right section.

    We have a 2003 R230 SL350 in the family - my father owned the car for 12 years. Recently, we've had an issue with certain electronic parts of the car not "waking up" when the key is turned to the first notch. I think it has to be an ignition switch problem? If so, do we need to go to the main dealer? Has anyone had the same issue?

    Thanks for your input.
     
  2. AMGeed

    AMGeed MB Club Veteran

    Messages:
    10,114
    Joined:
    Nov 1, 2008
    Location:
    Bournemouth/Poole Dorset
    Car:
    2004 W211 E55K ///AMG
    Welcome to the forum Adam,

    Are you anywhere near Birmingham?
    I ask as RMK can repair faulty ignition switches. They also have a mobile service but you have to book an appointment.

    ReplacementMercedesKeys - EIS Repairs
     
  3. OP
    OP
    adamcot

    adamcot New Member

    Messages:
    2
    Joined:
    Feb 5, 2017
    Car:
    Jaguar XE Alfa GTV
    I'm in Yorkshire, but I will give them a go! Thanks for the advice.
     
  4. duff

    duff New Member

    Messages:
    4
    Joined:
    Mar 28, 2011
    Location:
    Manchester
    Car:
    c220
    Hi I had an eis fail I used a company in Manchester autolockuk I took eis off and dropped it off with key he read eis info and it was corrupt he reprogrammed it while I waited and now all ok they do call out as well it cost £100. Think there's a company in Leeds don't know what there like. Hope this helps
     
  5. TonyWillis

    TonyWillis New Member

    Messages:
    10
    Joined:
    Dec 29, 2016
    Car:
    mERCEDES cl500 2004
    CL500 - 2004 - Problem with remote locking

    Help please!
    have a problem that seems to have 3 mercedes indies scratching their heads. I'm sure that some of the brains in the club will know what the solution is so here goes:
    Following a flat car battery and recharge, the remote central locking wouldn't operate. if the door is opened with the mechanical key to get in, put a key in the ignition and switch on and both keys work fine - start the car no problem, central locking works using either the dashboard buttons or the buttons on both keys everything works perfectly. take the key out of the EIS and doors and boot lock/unlock normally with both remotes for about 20 seconds then nothing! Put the key back in the ignition both keys work again. On key is brand new from mercedes for £240 and both have been tested.
    It's as if the EIS goes to sleep about 20 seconds after the key is taken out - during that time they both work remotely with no problem.
    Has anyone any ideas because I'm getting desperate now and hate to take it to main dealer
    Thanks
    Tony
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.