Radio 2 reception has be ome really poor

clanny

Member
Joined
Dec 23, 2011
Messages
48
Car
2004 E220 cdi
I've found that over the past few months my reception in my 04 w211 has become really poor at several points in my 55 mile commute. To the point that in places I just can't get it at all.

The others in my car pool don't have the same problem and none of the other stations suffer, so it can't be the ariel nor the transmitters. I can only think it's the signal for radio 2 is wandering (could be the bbc are phasing it out?) and my system is struggling to track the best signal.

Has anyone suffered this? Is there an update that I can do to my command or tuning system that'll help?

Any help gratefully received.
 

Ted

MB Enthusiast
Joined
Feb 26, 2004
Messages
5,916
Location
Bourton on Dunsmore
Car
SLC 250D AMG Line, Yamaha XVS 1100, Jeep Renegade
Are you charging your phone via a lead plugged into your fag lighter?
Try disconnecting it.
 
OP
OP
C

clanny

Member
Joined
Dec 23, 2011
Messages
48
Car
2004 E220 cdi
Hi Ted, thanks for your reply. I hadn't thought of it but that's what it was. Really odd that it was only for one radio station and only for certain parts of the journey. Anyway, I've got it down now. Time to do a little research on interference suppression on the net. Maybe a quick RC mod might smooth it out enough for proper radio operation.
 
D

Deleted member 6183

Guest
If it only occurred between 2pm and 5pm weekdays I'd consider it a blessing.
 

guydewdney

MB Enthusiast
Joined
Feb 14, 2004
Messages
2,904
Location
Porlock, Zomerzet
Car
906 Sprinter 313cdi
My aerial amp blew up, but it had been intermittent of late. If yours is an estate, yank off rhs rear panel (like the lhs one, but more enthusiasm required ) and the amp is the little fag packet size box. Check the connection to it. Mine set light:eek:
 

Users who are viewing this thread

Top Bottom