Random intermittent Comand centre, I.e. radio, satnav and reversing not working

Page may contain affiliate links. Please see terms for details.

philr123

New Member
Joined
Dec 3, 2023
Messages
4
Location
Uk
Car
Mercedes b200
Hi all

so 2016 B200 the screen and functions on Start up intermittently does not come on, sometimes they do and all functions normally, other times a minute or 2 down the road it will appear.
I have read about the cold reboot of the system by removing fuses and supply etc but to no avail also read aboutho
ding the eject button on the cd player for 15 seconds also nothing.
HELP.

tia

Phil
 
I’m not an expert but could it be a failing battery or simply not getting enough of a run to get the battery charged?
 
I’m not an expert but could it be a failing battery or simply not getting enough of a run to get the battery charged?
Hi, thanks for your input, it’s a new battery this year, and the auxiliary as well, but I will check the voltage later, you never know….
 
So it wasn’t the battery, that’s fine, any other ideas folks?
 
It could be a failing COMAND system, or a failing battery (have you checked the battery voltage as and after you have started it), or a failing battery sensor reporting the wrong voltage on the car's CAN network so the stereo decides not to turn on, (plus a load of other stuff). You need Xenrty Diagnosis to see the CAN battery voltage and look at other errors now as you've done the easy "battery voltage too low" tests I think !

R
 
It could be a failing COMAND system, or a failing battery (have you checked the battery voltage as and after you have started it), or a failing battery sensor reporting the wrong voltage on the car's CAN network so the stereo decides not to turn on, (plus a load of other stuff). You need Xenrty Diagnosis to see the CAN battery voltage and look at other errors now as you've done the easy "battery voltage too low" tests I think !

R
Thanks . Will look into it
 

Users who are viewing this thread

Back
Top Bottom