Rattle/buzzing c63

Page may contain affiliate links. Please see terms for details.

Wheelspk

New Member
Joined
Mar 24, 2024
Messages
25
Location
Pakistan
Car
C3
Hello guys,

I have a 2012 w204 c63 with 49k miles .
Stock exhaust, stock car.

I have this annoying rattling/buzzing a sound like a diesel engine running coming from the right side (RHD) every-time I accelerate on low speed in higher gear (normal city drive) from 2000rpm till 4000rpm

Video:

To view this content we will need your consent to set third party cookies.
For more detailed information, see our cookies page.

Every-time i let go of the accelerator paddle and apply some gas this metallic buzzing/ rattling sound comes, can be heard in the video.

I have taken the car to have the exhaust checked and found zero leaks, changed the header gasket just in case , didn’t fix it.
Checked the cats they were in good condition , even swiped then with my friends car but the sound is still there.

Anyone suggest what could be causing this sound inside the car, i can hear it very low when the car is in park and i give gas, but when driving it more noticeable.
 
Can't help but that would drive me mad is it interference with the stereo as it doesn't sound like engine or transmission noises 🤔
 
Can't help but that would drive me mad is it interference with the stereo as it doesn't sound like engine or transmission noises 🤔
No its not interfering with the stereo but its always there every time I accelerate .
 
I had a where is that coming from noise behind the dashboard in my C63. Drove me nuts for weeks and made me worry about what expensive part was failing. Anyway, the car was called in for a service which included a fuel line clean and the noise went away….. maybe!
 
Ya worth a try , this sound is coming from the right side of the engine in side the car and is driving me nuts every-time i drive this car .
 
cant hear much in the video but perhaps prop shaft bearing?
 
It just doesn't sound mechanical at all to me
 
Im sorry but thats the best I could record you might notice it every time i lift off the throttle it stops and ever time i give throttle it comes back.

Pro shaft has been checked its okay and balanced, yesterday i found out one of my engine mounts has failed and the 2nd one is also failing, but im not sure if thats what causing the sound as its a mechanical buzz/rattle.

Have ordered all three mounts, cant find out if that what causing it before i install it .
 
Im sorry thats the best video i could record, you might notice the sound like a buzzzzzzzz every time i press the throttle and it stops every time i lift off the throttle.

Also its there on low throttle on rpms around 2500rpms till 4000rpms after that the exhaust sound is too loud too hear anything but for normal drive its always there.
 
Im sorry but thats the best I could record you might notice it every time i lift off the throttle it stops and ever time i give throttle it comes back.

Pro shaft has been checked its okay and balanced, yesterday i found out one of my engine mounts has failed and the 2nd one is also failing, but im not sure if thats what causing the sound as its a mechanical buzz/rattle.

Have ordered all three mounts, cant find out if that what causing it before i install it .
If one or more of the engine mounts have failed then every time you apply the throttle or lift off the torque reaction will allow the engine to physically move more than it should, which could easily cause the noise.
They need doing anyway by all accounts, so have them fitted and hopefully that will solve your issue.

Probably not as bad as this, but you get the idea:
To view this content we will need your consent to set third party cookies.
For more detailed information, see our cookies page.
 
Last edited:
Ya im hoping thats the issue , mine not that extreme but its getting there if not changed.

Will report back once ill have em replaced.

Cheers
 
Update: took the intake off checked for leaks disnt find any, check all exhaust shields all are okay and non are vibrating, changed the engine mounts as one of them was bad but that still didn't solve the annoying buzzing sound on light RPM acceleration mostly btw 2500 rpms and 4000rpms

sounds like a exhaust leakage but there isn’t any leakage checked 3 times and 3 different shops.

its always there every time I accelerate on any gear when i let go and the apply accelerator paddle again.

video:


To view this content we will need your consent to set third party cookies.
For more detailed information, see our cookies page.

anyone could please suggest any thing to check it would be very helpful.
 
@alexanderfoti might be able to help if he has a minute to spare

It would be very helpful if would be given a direction what to check next as i have done all i could think of and this sound isnt going away .

As the sound is audible from the right (RHD) only thing i had checked are as follows.

Checks so far :

New mounts
Clean injectors
Checked cams for play (had none)
Check cam lobs ( are smooth)
Checked right lifters for wear ( didn't find any)
Checked right header leakage ( had none )
Checked exhaust leakage ( had none)

This rattle will not go away , and I'm helpless 😣
 
It's very very hard to hear in the video, so I'm basing this more on your description of the noise.

It does sound exhaust like. As your mounts had failed, have you checked for a cracked catalytic converter around the base of the weld at the top? It's hard to see and is common when mounts are poor.
 
It's very very hard to hear in the video, so I'm basing this more on your description of the noise.

It does sound exhaust like. As your mounts had failed, have you checked for a cracked catalytic converter around the base of the weld at the top? It's hard to see and is common when mounts are poor.

Thank for the reply

Yes i have checked for all sort of leakages as that what i suspected as well, changed the oem header and gasket as i suspected its a header leakage but that made no difference, i was very hopeful that changing the mounts would make this rattling sound go away but it didnt.



I have edited the video with captions every-time rattling happens on throttle and when it stops off throttle if you on a mobile i suggest u turn the volume too full im sorry this is the best i could capture.



Hope this video is better:



To view this content we will need your consent to set third party cookies.
For more detailed information, see our cookies page.



Checks so far i have done:



Inspected right hand (driver side) cams and lifters , cams lobs were smooth and lifters had minimal to no wear.

Changed mounts
Checked all exhaust leakage, changed cats , changed headers and gaskets.
Put new clean injectors
Took off and inspected the intake and TB all looked good no leakages.

Any suggestions what i could check too get rid of this rattle on throttle.

Thanks
 
Maybe my equipment... but I can't hear anything......except the change of engine note as you get on and off the throttle..... :confused:
 

Users who are viewing this thread

Back
Top Bottom