Re cl63 major engine issue

COLLEGE66

New Member
Joined
Jan 9, 2016
Messages
6
Car
CL63
Hi all,

I recently posted an issue regarding the extremely poor running of my CL63. Given the nature of the symptoms,which at first were thought to be electrical, my post was placed in the Electronics section. However, following an inspection by a well known local Indy yesterday, he established the following faults with car, following Star diagnostics. Can anyone offer me any advice please and what my options are, I.E new engine, re-build etc. The car has only covered 81,000 miles and has full MB service history.

Fault codes for misfiring on cylinders 1,5,6,7,8 in fault memory as well as
0760 (Left intake camshaft Hall sensor):The time of the signal value change
is implausible
Cleared fault memory and after cranking the fault code 0760 had returned.
Carried out compression test on Star. ECU reporting RPM difference of 267
RPM, maximum permissible difference 28 RPM. Suspect internal engine
damage with fault code 0760 perhaps indicating camshaft timing is out.

Thanks
 

WG M-B

Auhorised Forum Sponsor
SUPPORTER
Joined
May 26, 2011
Messages
1,897
Location
N/W london
Car
C63 Wagon in black
I would have to agree.
Your misfire codes largely relate the left bank.
 
OP
OP
C

COLLEGE66

New Member
Joined
Jan 9, 2016
Messages
6
Car
CL63
Thanks WG M-B

I have been told on some forums that some have had the timing corrected and their cars were fine. Sounds to good to be true, so could you let me know what your professional thoughts are on this please. I would also be interested to know what your advice would be on my next steps please.

Thanks
 

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

Top Bottom