Rear door ambient lighting issue

Paulsgaffe

New Member
Joined
Nov 25, 2020
Messages
4
Location
Romford
Car
C220
Hi all
I hope everyone is being safe and keeping well.
I have a 2016 Mercedes c220d and I love everything about the car, what I have found out lately is the passenger rear door ambient lighting isnt working correctly, when I select Amber all panels light up Amber, when I select blue all change except the rear passenger door it will stay Amber, if I select white all change to white.
Any tips or pointers to help fix this issue?
Any idea of cost to get this fixed?
it’s crazy I know and a very little fault but this is driving me crazy, I’d like to have blue all over.
Thanks in advance - Paul.
 

SmartAmg

MB Enthusiast
Joined
May 19, 2018
Messages
6,272
Location
St Helens
Car
2011 E class coupe 350 cdi
Any tips or pointers to help fix this issue?
Yep don't choose Blue, sorry, Paul couldn't resist, :rolleyes: no doubt someone will help you.
P.S. Purples best anyway. :)👍
 

Dc99

New Member
Joined
Nov 3, 2019
Messages
6
Location
Ireland
Car
S205
AFAIK the wiring for the 3 colour ambient lighting is three wires. One of which is negative and attached to ground.
the other two are what dictates the colour.
First wire - the negative (always)
second wire when are on - turns on white
third wire when are on - turns yellow
when second and third wire are on - turns blue

Please note the colours I have could be completely different - but hopefully I have made some sense?

so maybe there is a bad connection on that wiring harness in that door for the blue LED.

If your handy enough and can take the door card off - have a look at YT for installing ambient lighting to assist you in looking at it.

Is the blue light working at one end of the light distribution bar in the door? If that were the case I would look at the other end of the light distribution bar for a bad connection (it is unlikely that the LED is gone - but it could be) otherwise I would look for a bad connection at the feed end of the wire harness.

Hope I got the problem right and the above makes sense?
 
OP
OP
Paulsgaffe

Paulsgaffe

New Member
Joined
Nov 25, 2020
Messages
4
Location
Romford
Car
C220
AFAIK the wiring for the 3 colour ambient lighting is three wires. One of which is negative and attached to ground.
the other two are what dictates the colour.
First wire - the negative (always)
second wire when are on - turns on white
third wire when are on - turns yellow
when second and third wire are on - turns blue

Please note the colours I have could be completely different - but hopefully I have made some sense?

so maybe there is a bad connection on that wiring harness in that door for the blue LED.

If your handy enough and can take the door card off - have a look at YT for installing ambient lighting to assist you in looking at it.

Is the blue light working at one end of the light distribution bar in the door? If that were the case I would look at the other end of the light distribution bar for a bad connection (it is unlikely that the LED is gone - but it could be) otherwise I would look for a bad connection at the feed end of the wire harness.

Hope I got the problem right and the above makes sense?
Hi Dc99

what a great reply, explains everything, I removed the door card a while agoand found all wiring connections in good order, I bought and changed over the led light strip in the door. Connected up and all is working fine. I have since sold the car and went for an upgrade to a C250. I have a different issue now lol the sunroof rattles and makes noises that will drive you mad. When sun roof is open no rattle. As soon as you close it, that rattle is back. Never had that on my other car. I’m going to update profile pic and add this issue as a problem to be solved question for everyone. Thanks again.
 

Dc99

New Member
Joined
Nov 3, 2019
Messages
6
Location
Ireland
Car
S205
Hi Dc99

what a great reply, explains everything, I removed the door card a while agoand found all wiring connections in good order, I bought and changed over the led light strip in the door. Connected up and all is working fine. I have since sold the car and went for an upgrade to a C250. I have a different issue now lol the sunroof rattles and makes noises that will drive you mad. When sun roof is open no rattle. As soon as you close it, that rattle is back. Never had that on my other car. I’m going to update profile pic and add this issue as a problem to be solved question for everyone. Thanks again.
LOL - I should have looked at the date- glad you got sorted.
 

Users who are viewing this thread

Top Bottom