Rear seat stuck W203 estate

Discussion in 'Interior' started by Kings, Jun 14, 2011.

  1. Kings

    Kings New Member

    Messages:
    6
    Joined:
    May 20, 2011
    Location:
    Bristol
    Car:
    C320 CDI
    Hi all, I have gone to fold the larger section of the split rear seats and it is stuck solid, with the luggage cover firmly in place!
    The release handle has a bit of resistance, so I don't think the cable has unattached itself but possibly stretched.

    I have been searching the forum for others who have had the same problem on the W203 but have come up blank. (found lots of e class with the same problem)
    Would getting to the release mechanism be very similar on the e class as my W203, so I can make a start at tring to fix it.

    Any help/advice would be appreciated
     
  2. Tubz

    Tubz New Member

    Messages:
    27
    Joined:
    Mar 29, 2011
    Car:
    E320 CDi / Nissan 300ZX
    Any News on this as i have the same issue on my W210 estate and i'm pondering the Sledgehammer!! I have the rear driversside out and am able to access and release the middle catch but the latch on the Left is stuck fast...any way of getting into the seat to release this as the load cover is preventing me from getting at it with a screwdriver to attempt to release it..

    Any advice much appreciated..
     
  3. Tubz

    Tubz New Member

    Messages:
    27
    Joined:
    Mar 29, 2011
    Car:
    E320 CDi / Nissan 300ZX
    solved.

    solved. Used this link and the 9th post:

    Stuck rear seat 01 wagon - Benzworld.org - Mercedes-Benz Discussion Forum Or this, there is a pdf attached to post 16 of this link:
    http://www.benzworld.org/forums/w210...1-wagon-2.html

    Only addition would be to find the connecting rod in front of the catch as i tried looking behind it first! ...Remove the tabbed upholstry which slots in, in the front of the catch, pull back the upholstry a little and you'll see the connecting rod. Push down with some long pin-nose pliers to release it

    With so many others having this issue, you will note that the connecting rod simply pushes through an eye and is mounted with a plastic shim...It really needs a clip washer on the back, a clipped plastic shim/eyelet like the bottom end, or ideally it should have been mounted the other way around so that when the seat is folded flat it would be 'hooked' down into the hole, rather than able to fall out of it!

    Anyway, another problem solved thanks to this forum!
     
    1 person likes this.
  4. Andrew1068

    Andrew1068 Member

    Messages:
    58
    Joined:
    Apr 11, 2010
    Location:
    Germany
    Car:
    c32o cdi
    Had the same problem on my w203, you need to carefully remove the upholstery on the latch and then you can look into the mechanics of the latch ( covered in black plastic moulding) the cover will have to broken off to get to the connecting rod (runs vertically from grip to metal release mechanism) a new catch costs about 35 pound (40 euros)
    heres the part mumber A2039200672
    good luck
     
    1 person likes this.
  5. OP
    OP
    Kings

    Kings New Member

    Messages:
    6
    Joined:
    May 20, 2011
    Location:
    Bristol
    Car:
    C320 CDI

    thank you for the info, I am going to try to fix this weekend
     
  6. OP
    OP
    Kings

    Kings New Member

    Messages:
    6
    Joined:
    May 20, 2011
    Location:
    Bristol
    Car:
    C320 CDI
    My seats now fold!
    I had to break the handles on top of the seats, to be able to gain access to the vertical rod that had come disconnected from the handle because of the small circular plastic locating lug had bent & split, dislodging the rod.
     
    1 person likes this.

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.