Removal/install of parking sensor

mobeyone

MB Enthusiast
Joined
Apr 23, 2005
Messages
1,432
Car
E280 S211
Anything I need to know? I understand that when in gear, the faulty sensor will make a clicking sound? is this correct?

Do they turn a certain way? and do I have to use silicone when inserting the new one? and is it simply plug and play?

I am pretty certain its a rear sensor, the fronts light up and beep but the rears just display the two red dots and then nothing.

tia
 

corned

MB Enthusiast
Joined
May 2, 2008
Messages
3,894
Location
Living in error with Maude at Cap Ferrat
Car
car
It WILL be one (or both) of the two outer ones at the back. Guaranteed. They cop all the muck and water thrown up straight at them by the rear tyres. Another example of marvellous MB engineering. The rubber / silicone boots which are supposed to cover them are not up to the job of keeping all the muck and water out, and so the sensors eventually fail.

On the plus side, they are a piece of cake to access, and once you know what you are doing you don't even need to venture under the car. You can get the old one out, and the new one in, simply by kneeling next to the bumper and reaching underneath. Pull the boot back and away up the wiring loom, open the top and bottom clips which hold the sensor in place, and pull the sensor towards the front of the car. Then unclip and withdraw the wiring connector.

With a new sensor, do the reverse procedure, making sure the wiring connector and sensor socket are scrupulously clean and dry. Two-minute job, seriously.
 
OP
OP
mobeyone

mobeyone

MB Enthusiast
Joined
Apr 23, 2005
Messages
1,432
Car
E280 S211
Thanks guys)

Done, more scared about breaking it than anything but easy and 5 mins tops. I knew which one was out and it's now working))
 

Users who are viewing this thread

Top Bottom