Reset ABS/ESP lights after sensor change - w204

Discussion in 'Wheels, Tyres, Brakes & Suspension' started by sceh, Jul 22, 2017.

  1. sceh

    sceh Active Member

    Messages:
    96
    Joined:
    Jul 31, 2015
    Car:
    w123 240TD
    I had these lights and the run flat one come on. I found one of the sensors at the rear had an open circuit so I changed it. How do I now clear the lights on the dash (apart from sticky tape :)) ? I did this same change on a Toyota dn it cleared automatically when it found the new sensor. Either Mercedes don't do this or there is another fault I suppose?

    thanks
     
  2. OP
    OP
    sceh

    sceh Active Member

    Messages:
    96
    Joined:
    Jul 31, 2015
    Car:
    w123 240TD
    I checked the resistance of the old sensor and it is definitely infinite so it is open circuit. I checked the new one and it is odd - it briefly indicates 1800 or so and then goes open. I am assuming this is something to do with the internal circuit of the sensor? Normally you should check these by turning the wheel but since it is the rear it is a bit of a problem.
    any tips?
     
  3. OP
    OP
    sceh

    sceh Active Member

    Messages:
    96
    Joined:
    Jul 31, 2015
    Car:
    w123 240TD
  4. OP
    OP
    sceh

    sceh Active Member

    Messages:
    96
    Joined:
    Jul 31, 2015
    Car:
    w123 240TD
    I finally found it was a front sensor and the one I bought was duff. I exchanged it for a Bosch sensor and, contrary to what MB told me, as soon as the sensor was detected, all the warning lights disappeared. Most cars work this way btw
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.