s class wont start

Discussion in 'Engine' started by Craigt, Sep 17, 2011.

  1. Craigt

    Craigt New Member

    Messages:
    20
    Joined:
    Dec 8, 2010
    HELP !!!

    I have a 2000 s class.

    i have a problem, i understand, with my drivers side door. so i asked my friends dad to have a look (hes an electronics engineer), he checked wiring etc, also one by one checked the fuses, all seems ok, so guessing its a problem with the module itself.

    However !!! now ive got a bigger problem - the car wont start, i mean it wont crank over ! turning the key you have 'ignition' lights but nothing not even a sound when you turn the key fully.

    Please Help
     
  2. MERC CLK 230 K

    MERC CLK 230 K Hardcore MB Enthusiast

    Messages:
    153
    Joined:
    Aug 27, 2011
    Location:
    kent
    Car:
    mercedes clk W208 230 kommpressor
    Is the engine turning
     
  3. MERC CLK 230 K

    MERC CLK 230 K Hardcore MB Enthusiast

    Messages:
    153
    Joined:
    Aug 27, 2011
    Location:
    kent
    Car:
    mercedes clk W208 230 kommpressor
    You may need a crankshaft sensor
     
  4. DSM10000

    DSM10000 MB Club Veteran

    Messages:
    6,114
    Joined:
    Jul 12, 2011
    Location:
    Near Salisbury
    Car:
    E32O CDi Sport, MX5 1.8 Sport, RR 4.2 SC
    Battery? check voltage and then try a ump start?
     
  5. mercedescl500

    mercedescl500 Hardcore MB Enthusiast

    Messages:
    816
    Joined:
    Mar 28, 2008
    Location:
    West London
    Car:
    CL500 with Brabus Bits and 1 Big Suprise
    Check every single fuse in the engine compartment (on the drivers side). I cant remember the fuse number but you might just find your problem there. I had a friend with a similar problem and when we replaced a single fuse in that fuse box it cranked and started immediately. HTH
     
  6. OP
    OP
    Craigt

    Craigt New Member

    Messages:
    20
    Joined:
    Dec 8, 2010
    Thanks all, Engine is not turning, ive checked the bttery voltage, all good, even tried a jump start but no luck, also checked fuses all good !!

    Help, just realised i cant move the car either as its stuck in Park !!
     
  7. mercedescl500

    mercedescl500 Hardcore MB Enthusiast

    Messages:
    816
    Joined:
    Mar 28, 2008
    Location:
    West London
    Car:
    CL500 with Brabus Bits and 1 Big Suprise
    First do not jump start your Mercedes, you can very easily overload a SAM unit. Secondly have you checked your starter motor for power ? and also more importantly have you checked the motronic/starter motor relay which is located in the engine compart inside the black fuse box (on the drivers side). Check the relay closest to the firewall. HTH.
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.