S320L CDI W221 Water & Oil leak 2007 72k

ScottHarry

New Member
Joined
Sep 21, 2013
Messages
12
Location
East Yorkshire, UK
Car
W221 S320L CDI 2007
Hi,

I’ve noticed two small water leaks side by side on the driveway which both left a small trail when I reversed. The pic shows the stood and reversed water.

On raising the hood I found an oil leak to the LHS of the engine with some oil behind the LHS of the radiator and then some leading away from the radiator to a recess containing pipes to the left of the Oil filler/cap.

Also noticed some maybe oil vapour on the bonnet lining above the oil leak location but this couldn't get through the plastic engine cover!? matbe nothing to do with this.

I’m not sure if the car has developed two problems - water and oil or both are connected in some way.

Just want to know if anyone can give me an idea what this is thanks. Grateful if you can.

I've taken some pictures and a short vid to capture engine audio here

thanks
 
OP
OP
ScottHarry

ScottHarry

New Member
Joined
Sep 21, 2013
Messages
12
Location
East Yorkshire, UK
Car
W221 S320L CDI 2007
Been having some thoughts on this oil leak of mine. Just wondering if it could be possible that the main dealer hasn't secured the oil filler top properly after service or the top has a bad seal and this is what is causing the small oil slick in this area of the engine? Both the oil run marks and the slick can be seen in picture no.2.

1. Car engine after buying from Mecedes Retail Group Sept 2013 - engine and oil filler very clean. Oil filler top never removed by me - only dip stick checked. No oil runs noted!

S320CDI%20W221%20Oil%20filler%20Sept2013.jpg



2. Car serviced by main dealer late Jan 2014 - engine oil changed


3. Car engine now May 2014 - with oil run marks leading from oil filler top. Sill oil filler top never removed by me - only dip stick checked - until last Sunday that is - day of nightmare :eek: Note oil slick to bottom of the engine.

S320CDI%20W221%20Oil%20filler%20May2014.jpg



5. Oil vapour passing up from oil filler cap area and vaporising on the noise reduction felt on the inside of the bonnet/hood.

a
S320CDI%20W221%20oil%20vapour%20inside%20of%20bonnet%20in%20oil%20filler%20area%20May%202014%20%281%29.JPG


b
S320CDI%20W221%20oil%20vapour%20inside%20of%20bonnet%20in%20oil%20filler%20area%20May%202014%20%282%29.JPG


6. Oil filler cap loose noted on another guys W221: post by MacTech on here


Any advice on how to go about getting this fixed - mobile mechanic to check it before I drive it any where, then indi or main dealer to fix it - ideas most welcome?

Cheers
Scott

PS I've found that Google Drive (GD) can host pictures for the site :bannana:
This means that you can store your pics for the site in a Google Drive > Cars > CarX folder on your PC, this will auto invoke GD to upload them to the web Google Drive for you in the background and then you share them from there ;) directly into your post like I have here using the 'insert image' yellow envelop looking button. Works a treat and I think GD gives you 1GB of free storage :D Also Google have very powerful servers as you can imagine so image recall should be quite quick and I believe pictures don't have to be reduced in size within reason.

Might be a good idea to add Google's instructions for this which are here to the sticky on how to remotely host pictures.

If anyone know of a problem in doing this this way please let me know - cheers
 

BlackC55

Authorised Forum Sponsor
SUPPORTER
Joined
Feb 8, 2007
Messages
19,767
Location
Portsmouth, Hampshire.
Car
E55K SL500 E250X2 Smart44 Brabus Track car E450Cabriolet X350 Pick up
The oil leak from the cap is very very common. We se it a lot when they are not put back on properly. Usually it knackers the alternator too as it fills it up with oil.

The water leak will be from the air con I suspect. It is normal.
 
OP
OP
ScottHarry

ScottHarry

New Member
Joined
Sep 21, 2013
Messages
12
Location
East Yorkshire, UK
Car
W221 S320L CDI 2007
Can any of you guys tell me what the black pipe does / is called highlighted in the pic below?

Also is it possible for this to be the cause of the oil leak in this area?

On pulling the black cover (where it joins the alloy casting) it is loose - is this normal?

It seems to be the highest point on the engine that oil is leaking from. The oil is running down the engine in the location/direction of the arrow.

Many thanks in advance :thumb:

PS I'm amazed how these pics zoom-in! Clicking the top yellow bar above the pic expands but if you then click the pic again even more magnification occurs! Well it does when using Chrome browser, not sure about the rest :D

Oil on pipe to breaking system S320CDI W221 May 2014 (2).JPG
 

AdamG

Active Member
Joined
Sep 16, 2006
Messages
133
Location
Bromley, Kent
Car
W210 E240 yr 2000 (stolen), W220 S320CDI (2003)
I think it is the vacuum pump for the brake system.

My w220 vacuum pump leaked there too. The solution was to remove the pump and undo the three torx screws (one is marked with yellow tamper paint). Once apart I applied a very small bead of rtv sealant and it's been leak free for 5 years now.

The black connection on mine is a little loose as well. It is a vacuum line so probably tightens up when the engine is running.

Adam
 
OP
OP
ScottHarry

ScottHarry

New Member
Joined
Sep 21, 2013
Messages
12
Location
East Yorkshire, UK
Car
W221 S320L CDI 2007
Many thanks Adam for explaining this to me - yes the pipe does lead to the breaking system reservoir tank. So its the vacuum pump for that.

Interesting that you had the same problem and good to hear you fixed yours and it's lasted for 5 years :)
Cheers
 
OP
OP
ScottHarry

ScottHarry

New Member
Joined
Sep 21, 2013
Messages
12
Location
East Yorkshire, UK
Car
W221 S320L CDI 2007
Always check your oil cap is tight immediately after a service - as possibly the service technician had a text/email/tweet/instagram/facebook message/etc on their smartphone in the middle of the operation, had a read of it, took their mind off their work and forgot something!

(The smartphone comment is a possibility that I have thought of what may have happened)

Many thanks to the people that replied here much appreciated.

Just to let you guys know what the confirmed fault cause was... I ended up taking the car to an independent MB specialist who has all the MB training certs on his reception wall inc S-Class.
He confirmed that the oil found in the 4 main areas was from the oil cap not being fitted correctly - oil vapour etc and the oil cap in itself was OK.

From what I stated in the previous posts within this thread it's happened during the main dealer service but nothing can be proven.

Oil found (all as pics above):
1. Running down from the oil filler & below the oil filler and in gully left of oil filler
2. On and below the vacuum pump for the breaking system
3. Left hand end of the radiator and adjacent pipes
4. Oil vapour on the bonnet/hood sound dampening felt above the oil filler
 

Users who are viewing this thread

Top Bottom