S350 not starting

Page may contain affiliate links. Please see terms for details.

TinaC

New Member
Joined
Nov 8, 2023
Messages
2
Location
glasgow
Car
Merc S350 Bluetec
Looking for help and advice, got a merc S350 bluetec had/has a starting problem. When key is put in ignition and turned the engine management light come on but no spiral for the spark plugs. Keep trying for 10 – 15 mins and suddenly coil light comes on and car starts.

Have changed the glow plug relay – changed the main car battery, started fine for one week 1st time then still same problem then changed the starter motor relay and it started 1st time and did so for 2 weeks, now it has returned to no spiral light on and back to keep trying until it decides to show spiral light again.

Thoughts and ideas appreciated.

Fingers crossed.

Tina
 
Looking for help and advice, got a merc S350 bluetec had/has a starting problem. When key is put in ignition and turned the engine management light come on but no spiral for the spark plugs. Keep trying for 10 – 15 mins and suddenly coil light comes on and car starts.

Have changed the glow plug relay – changed the main car battery, started fine for one week 1st time then still same problem then changed the starter motor relay and it started 1st time and did so for 2 weeks, now it has returned to no spiral light on and back to keep trying until it decides to show spiral light again.

Thoughts and ideas appreciated.

Fingers crossed.

Tina
You need a diagnostic fault code check to see what’s up .
 
With a bit of luck, it may just be a loose connection somewhere . . .
 
Its probably going to be a control unit of some kind. Usually a front SAM or engine control unit. Needs proper diag to find that out.
 

Users who are viewing this thread

Back
Top Bottom