sat nav, cd/radio, clock fault

Page may contain affiliate links. Please see terms for details.

Tubbasher

New Member
Joined
Apr 28, 2023
Messages
11
Location
Nottinghamshire UK
Car
2007 E220cdi AvantGarde W211
hi everyone I have a MB E220cdi w211 2007 the sat nav cd/radio and clock do not work does anyone know what controls these units and where it is situated on the car thanks
 
hi everyone I have a MB E220cdi w211 2007 the sat nav cd/radio and clock do not work does anyone know what controls these units and where it is situated on the car thanks
So the whole command unit is dead ?
 
So the whole command unit is dead ?
Thats correct there is nothing happening at all it started when the battery was draining over about two days , a mechanic said it was due to a certain unit which I cannot remember what he called but said he had disconnected but didnt say where it was situated and I dont want to take it back to him if I can fix it myself any imformation would be a great help.
 
Would start with the fuse(s) maybe… check and re-seat the one(s) that relate to the problem. Did this on a Cayenne entire infotainment system went down and totally unresponsive to button pressing, restarting the car multiple times etc… checked a couple of fuses, reseated them and system turned back on as normal.
 
Would start with the fuse(s) maybe… check and re-seat the one(s) that relate to the problem. Did this on a Cayenne entire infotainment system went down and totally unresponsive to button pressing, restarting the car multiple times etc… checked a couple of fuses, reseated them and system turned back on as normal.
thanks for your help will try as you suggest
 
not had chance to look at it yet mate Ive got to work on it outside so waiting for a dry day, is the control for the sat nav etc in the boot do you know because the mechanic said he had disconnected a unit that controls all that is now not working be cause it was draining the battery overnight which is now ok.
 
Not sure what they have disconnected exactly and from where... could it be amplifier in left rear wheel well due to water damage if that applies to your model?
 
not had chance to look at it yet mate Ive got to work on it outside so waiting for a dry day, is the control for the sat nav etc in the boot do you know because the mechanic said he had disconnected a unit that controls all that is now not working be cause it was draining the battery overnight which is now ok.
Won't it start draining the battery again ??
 

Users who are viewing this thread

Back
Top Bottom