SL320 pinging alert when driving

Discussion in 'Electronics' started by Gilbo41, Sep 29, 2011.

  1. Gilbo41

    Gilbo41 New Member

    Messages:
    2
    Joined:
    Sep 29, 2011
    Car:
    1996 sl320
    Hello, newbie here. Have a 1996 SL320 that normally behaves well but today there's a loud pinging alert sound that started after we'd been driving for 2-3 miles and continues whenever the key is at ignition stage 2, whether the engine is running or not.

    Recently the battery was completely flat after a week or two of non-use. This is not normally a problem, it usually holds its charge well. We jump started the car and noticed various features only worked as the battery gained a fuller charge: e.g. window single click full open / window drop & back up when opening or closing the door.

    Have looked for obvious things: i.e. opened & shut doors, boot, bonnet; removed the hard top, closed and re-opened the soft top, put the hard top back on again. No joy - as soon as the ignition key is turned to stage 2, the pinging alert goes again.

    Help please!!!
     
  2. Doodle

    Doodle Hardcore MB Enthusiast

    Messages:
    4,801
    Joined:
    May 3, 2005
    Location:
    Echo Beach
    Car:
    R129, Leon Cupra 290, BMW R100
    Have you folded the seat forward recently? Sometimes it whines because it thinks the backrest isn't locked. Redo it and give it a gentle slam to close.
     
  3. Sp!ke

    Sp!ke Administrator Staff Member

    Messages:
    12,234
    Joined:
    Jun 2, 2002
    Location:
    West London
    Car:
    SL500 & The Fart Car
    Mine pings if the seat backs arent in place or if the hood isnt correctly fastened or if the handbrake is on. Perhaps one of those sensors is at fault.

    Best thing is to get it on a star machine and see rather than spend ages doing trial and error.

    If you say where you're based maybe someone can recommend a friendly independent specialist.
     
  4. Doodle

    Doodle Hardcore MB Enthusiast

    Messages:
    4,801
    Joined:
    May 3, 2005
    Location:
    Echo Beach
    Car:
    R129, Leon Cupra 290, BMW R100
    Would that show up on a 1996 car? Obviously it's all pervasive on the new cars, but I've often wondered how far the STAR diagnostic reaches on the older models.

    On mine the pinging is accompanied by a flashing light to give you some idea of what is wrong.
     
  5. Stratman

    Stratman Hardcore MB Enthusiast

    Messages:
    4,568
    Joined:
    Jun 15, 2003
    Location:
    Sunbury
    Car:
    W203 C200 CDI '04Estate
    Try fastening the passenger seatbelt, see if the pinging stops then.
     
  6. OP
    OP
    Gilbo41

    Gilbo41 New Member

    Messages:
    2
    Joined:
    Sep 29, 2011
    Car:
    1996 sl320
    Hi folks, thanks for all your replies. I have tried the front seat, hood & seat belt things, but no joy. I'm in Buxton, Derbyshire, near Stockport - does anyone know of a good independent Merc garage near me?
     
  7. Stratman

    Stratman Hardcore MB Enthusiast

    Messages:
    4,568
    Joined:
    Jun 15, 2003
    Location:
    Sunbury
    Car:
    W203 C200 CDI '04Estate
    Take a look at this thread. Post 5 isn't too far from you in Rotherham.


    Welcome aboard by the way :thumb:
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.