SL55 Slight Vibration

karozza

Active Member
Joined
Nov 21, 2009
Messages
516
Location
MALTA
Car
SL55 AMG/C180 K
I keep feeling a very slight vibration(hardly noticeable) in the steering at around 40-50mph similar to wheels not balanced properly, front have both been balanced again. Unfortunately not that easy to go over that speed here, at least for any distance except for a quick dash.

But, when I go to Sicily, I'm pretty sure it goes away at high speed.

Tyres are practically new & no uneven wear, running on aftermarket 19" alloys.

Are there any other places on the car I can check?
 
OP
OP
karozza

karozza

Active Member
Joined
Nov 21, 2009
Messages
516
Location
MALTA
Car
SL55 AMG/C180 K
Tyres are Bridgestone RE050A MO1 & the left front rim has a very slight buckle which the tyre fitter said should not have affect after balancing.
 

merc85

MB Enthusiast
SUPPORTER
Joined
Apr 23, 2013
Messages
9,193
Location
Harwich
Car
s211 e55k
Could be the Wrong Size Spiggot rings, or Poor quality rings, I had to fit Alloy rings to mine to cure the wobble.

If you dont have rings fitted and the centre bore of the wheel is bigger than the hub of the car this will also cause the above.
Also if they are the correct centre bore eg 66.6 then check your lower thrust arms.
 
OP
OP
karozza

karozza

Active Member
Joined
Nov 21, 2009
Messages
516
Location
MALTA
Car
SL55 AMG/C180 K
No Spigot rings applied. To my knowledge, centre bore of the wheel is correct size as we take off & refit wheels our wheels.

Thanks for input.
 

merc85

MB Enthusiast
SUPPORTER
Joined
Apr 23, 2013
Messages
9,193
Location
Harwich
Car
s211 e55k
Id be looking at a Out of shape wheel, Worn Thrust arms, Slightly bent hub/flange, Wheel bearings, warped disc's

At least thats all the stuff i went through to sort mine. I nearly ended up fitting a new steering rack as the damper is built into it.
 
OP
OP
karozza

karozza

Active Member
Joined
Nov 21, 2009
Messages
516
Location
MALTA
Car
SL55 AMG/C180 K
Yes, I'm going with the Out of shape wheel but thought that would have been picked up when balancing!?
 

MicB

MB Enthusiast
Joined
Nov 2, 2010
Messages
1,037
Location
Beckley, Oxford
Car
MB SL500 (R230) 2003, MB SLK320 (R170) 2001, Volvo V70 XC AWD 2001
Could it be a gear the box mounting? Extract from my diary:

19 December 2013 (93670 miles)

The car was driving as if it was always being driven on a corrugated surface.
Replace gear box mount.
Star Motor Service

Mic
 

Users who are viewing this thread

Top Bottom