SLK 320 dangeously slw acceleration from stop

Discussion in 'Engine' started by Hopward, Apr 13, 2014.

  1. Hopward

    Hopward New Member

    Messages:
    4
    Joined:
    Apr 12, 2014
    Car:
    Slk 320
    I Guys,

    This is my fist posting so hopefully I have done it correctly .
    I have a 2001 SLK which I have owned for a year. She has full MB service history and just 59,000 miles.
    Sometimes such as yesterday, she just would not accelerate from standstill. It was like she had fallen asleep and the long, long lag to get speed up can be dangerous as even leaving a very large gap when pulling into traffic she accelerates so slowly that the traffic catches up and the only way I can build up speed is to floor the throttle literally.

    I have of course done the obvious checks such as making sure she is in "drive". The handbrake is not on. I am not accidentally braking with my other foot and the engine still sounds like all cylinders are firing.

    Mostly she runs fine and is a joy, but 20% of journeys are a nightmare for the reasons stated above.

    Can someone please advise me what might be wrong !
    It is spoiling my ownership experience.
    :(
     
  2. m2287

    m2287 Hardcore MB Enthusiast

    Messages:
    2,646
    Joined:
    Jan 27, 2010
    Location:
    cambridge
    Car:
    Bentley Continental GT
    I have similarish issue, with mine I think it's the throttle pedal, I'm waiting on my new one to arrive! However your problem could be a variety of things, the best place to start would be by getting it plugged in on STAR.
     
  3. OP
    OP
    Hopward

    Hopward New Member

    Messages:
    4
    Joined:
    Apr 12, 2014
    Car:
    Slk 320

    Thanks. what is STAR please.
     
  4. m2287

    m2287 Hardcore MB Enthusiast

    Messages:
    2,646
    Joined:
    Jan 27, 2010
    Location:
    cambridge
    Car:
    Bentley Continental GT
    It's the official mercedes diagnostic tool... Most merc specialists will have one
     
    1 person likes this.
  5. Ted

    Ted Hardcore MB Enthusiast

    Messages:
    4,973
    Joined:
    Feb 26, 2004
    Location:
    Bourton on Dunsmore
    Car:
    A209 CLK AMG Sport Convertible, Yamaha XVS 1100, Jeep Renegade
    Had similar to that on a clk and a new maf sorted it out.
    However one member was also experiencing similar symptoms and it turned out to be a badly adjusted brake light switch.
     
    1 person likes this.

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.