Speed limit on W211

Le Burpor

Member
Joined
Jun 5, 2003
Messages
31
Car
2004 E320; 2002 A160
I took my E320 on the highway a few nights ago and went upto 220 km/h. At that point I felt like the engine backed off a bit and I could not accellerate past 220 km/h. I also felt like there was something 'limiting' the engine from reving any higher.

Is 220 km/h the limit that's imposed on the E320? I always thought it was 250 km/h??
 

RichardM

MB Enthusiast
Joined
Jan 29, 2003
Messages
2,490
Location
Essex
Car
2011 CLS350 CDI
Aren't you supposed to run the car in before doing that sort of speed! And I thought Australia had stricter speed limits than here.
 

fuzzer

MB Enthusiast
Joined
Jun 1, 2002
Messages
7,939
Location
Glasgow
Car
F25 X3 20d SE
Originally posted by RichardM
Aren't you supposed to run the car in before doing that sort of speed!

I didnt want to put a downer on things by saying that.

Suppose you can run the car in quicker at that speed :)
 

scotth_uk

MB Enthusiast
Joined
May 16, 2003
Messages
2,570
Location
Sydney
Car
Renault
Most car manufacturers admit now that there is no run-in period required.

I could not accellerate past 220 km/h

On your trip to the Northern Territory? ;-)
 
Last edited:

Maff

MB Enthusiast
Joined
Jun 4, 2002
Messages
2,485
Location
Henley-on-Thames
I know that the 'old version' ML320 for instance had a limiter at 112mph due to tires, however the ML430 limter was higher. Might be worth checking the tires and whats in your cars computer.

In my CL it constantly kept telling me that I could not go any faster than 130mph due to tires, however the limiter didn't seem to work :)
 

Brian WH

MB Enthusiast
Joined
Aug 21, 2002
Messages
6,283
Location
East Midlands
Car
JAGUAR XF 3.0D Premium Luxury
Originally posted by scotth_uk
Most car manufacturers admit now that there is no run-in period required.

I would still run in the Engine on a Mercedes.

The reason that it was "backing off" is that the engine is still "Tight" and needs bedding in for the first 1500 miles,or 2400 Km.

The top speed of the E320 is 149mph or 240 kph, not 250. You should be able to attain it when it is RUN-IN mate.:cool:
 
OP
OP
L

Le Burpor

Member
Joined
Jun 5, 2003
Messages
31
Car
2004 E320; 2002 A160
My dealer had infact told me that I did not have to run in the engine. He made the claim that the engine would have had at least 20 hrs of running prior to shipping. Whether this is true or not I have no idea.

I did the 220 km/h run after having around 400 kms on the odo. The car seems to run quieter and smoother now...but to think I could have risked damage to the engine is a bit scary :eek:

Australia does have a lower limit than 220 km/h. I was just in one of those areas where you hardly ever see cops there :D

I just drove through the area where I did that speed again and realise that there is a slight incline, I guess this could have affected the speed as well.

Will I try that speed again...I doubt it :crazy:

Overall, it was a very smooth ride, wind and road noise was minimal even at 220. I would even go so far to say that it's slightly quieter than the S430...then again...I may have to test that theory heh :devil:
 

akmal17

Active Member
Joined
Jun 22, 2003
Messages
171
Location
U.K.
we were also told to take it easy for the first 1,000 miles. weve done 620 miles now, and the fastest weve been is 90mph and the car feels very smooth. car seems to be returning about 31mpg so far:confused: could it be b,coz of the cold weather? (altough today it did 35mpg:D) car feels very smooth though, i remember we had an s320 cdi a month b4 we took delivery and i gotta say this car is just as smooth....but without airmatic :)

brian, 149 is the top speed for the e320, but top speed for the 320 cdi is 151mph :D :D :D

AkMaL
 

Brian WH

MB Enthusiast
Joined
Aug 21, 2002
Messages
6,283
Location
East Midlands
Car
JAGUAR XF 3.0D Premium Luxury
Originally posted by akmal17
brian, 149 is the top speed for the e320, but top speed for the 320 cdi is 151mph :D :D :D

AkMaL

I did not like to mention that mate.:D :D LOL

Mine has more torque too, but who's bragging.:D :D
 
OP
OP
L

Le Burpor

Member
Joined
Jun 5, 2003
Messages
31
Car
2004 E320; 2002 A160
Originally posted by Brian WH
I did not like to mention that mate.:D :D LOL

Mine has more torque too, but who's bragging.:D :D

Grrrr...... :mad:

I've got double sun shades...so there! :rock:

..lol...
 

Users who are viewing this thread

Top Bottom