Speedo troubles

Discussion in 'General Discussion' started by Reggies, May 5, 2017.

  1. Reggies

    Reggies New Member

    Messages:
    22
    Joined:
    Mar 30, 2017
    Car:
    C180 Elegance 1995
    On my old car 1995 c180, the speedo dose not work for 3 to 5 mins, then it is ok, when I stop the engine and re start it, yet 3 to 5 mins again, then it all works.
    It is only the speedometer, now this is not the end of the world but just wondered why it dose this.
    :crazy:
     
  2. Ted

    Ted MB Club Veteran

    Messages:
    5,578
    Joined:
    Feb 26, 2004
    Location:
    Bourton on Dunsmore
    Car:
    SLC 250D AMG Line, Yamaha XVS 1100, Jeep Renegade
    Sounds like the needle is sticking against the stop.
     
  3. Pontoneer

    Pontoneer MB Club Veteran

    Messages:
    12,129
    Joined:
    Aug 19, 2002
    Location:
    Ayrshire
    Car:
    '93 190E 2.3LE W201 ; '93 300SL-24 R129
    W202 was one of the first MB models to be heavily dependant on electronics , and they are known for gremlins in this area .
     
  4. Dec

    Dec Hardcore MB Enthusiast

    Messages:
    4,475
    Joined:
    Jul 28, 2004
    Car:
    C180,A.
    Heat inside the cluster softens the paint and the needle sticks to the needle stop.
    Try a thump on top of cluster to see if it gets the needle moving.

    Dec

    [​IMG]
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.