Sprinter rear lights

guydewdney

MB Enthusiast
Joined
Feb 14, 2004
Messages
2,904
Location
Porlock, Zomerzet
Car
906 Sprinter 313cdi
Hello

Back again. Got a sprinter now. 2007 with startship mileage.

Anyway. Today involved adding a reverse camera and tow bar.

Fitted camera first. Tested fine. All done and dusted.

Fitted towbar, really easy, except the wiring. I paid extra for a kit specific to the sprinter.

Connected the can bus module to the X3 connector, pin 11 as described in the manual.

Now I have no rear lights whatsoever. Brake, tail, fog, indicator hazard and reverse.

All other lights work, including side markers.

Checked every fuse under the left end of the dash and the three or four under the driver's seat. None blown.


Any suggestions?

Thanks

Guy
 

toolman1954

MB Enthusiast
SUPPORTER
Joined
Sep 16, 2004
Messages
1,102
Location
Leven, Fife / Northampton
Car
2003 320 CDI Avantgarde, 1997 312d Sprinter
Hi,
Adding a dedicated wiring harness for the towing electrics normally ( for cars ) needs to be coded in on a Star Diagnostic, have you checked whether this is necessary on a van.

Steve
 
OP
OP
guydewdney

guydewdney

MB Enthusiast
Joined
Feb 14, 2004
Messages
2,904
Location
Porlock, Zomerzet
Car
906 Sprinter 313cdi
turns out the wiring harness tapped into the brake wire in connector X3, pin 11. this cheesed off the SAM as I think the brake and tail lights are one wire. so the sam shut down everything.

remove this - let the system reboot. harness has a canbus interface which deals with the brake light.

all working again.
 

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

Top Bottom