SRS problems & Exhaust suppliers

Discussion in 'Engine' started by Conor, Jul 28, 2008.

  1. Conor

    Conor New Member

    Messages:
    3
    Joined:
    Jul 18, 2008
    Hi, I have a 2000 E320 CDi Avant garde Estate. I drove over a tree stump in a French carpark ( not smart, I know but I didnt see it) and there was a heavy impact. No physical damage but the red SRS warning lamp lit up on the dash & the Airbag off light also has come on. Does anyone know a fix for this?

    Also I will need a new back box for this car soon - is there a good quality spurious one out there as the Dealer wants c. €300 - not cheap for a back box.

    Cheers,
    Conor
     
  2. recycled

    recycled Hardcore MB Enthusiast

    Messages:
    4,278
    Joined:
    Feb 26, 2007
    welcome. where abouts are you? have you tried eurocarparts or ces?
     
  3. SilverSaloon

    SilverSaloon MB Club Veteran

    Messages:
    7,759
    Joined:
    Mar 16, 2004
    Car:
    1994 W124 E300D Estate, 1985 R107 280SL
    have the wires bumped out from underneath the seats? (seatbelt pretensioner wires?)
     
  4. recycled

    recycled Hardcore MB Enthusiast

    Messages:
    4,278
    Joined:
    Feb 26, 2007
    try underneath the passenger seats, to see if you have dislodged the SRS unit for the passenger under there.
     
  5. Dieselman

    Dieselman Banned

    Messages:
    34,206
    Joined:
    Jul 13, 2003
    Car:
    Peugeot 403 Convertible
    The bash has probably upset one of the lateral force sensors. You need the codes read to find which one.
     
  6. SilverSaloon

    SilverSaloon MB Club Veteran

    Messages:
    7,759
    Joined:
    Mar 16, 2004
    Car:
    1994 W124 E300D Estate, 1985 R107 280SL
    you'll also probably need to get the light reset once you have reconnected the pretentioner wires on a W210
     
  7. OP
    OP
    Conor

    Conor New Member

    Messages:
    3
    Joined:
    Jul 18, 2008
    I disconnected/re-connected the 3 push fit connectors(not great quality) under the seat but no change to either light. Is there another connector for the pre-tensioner?

    Also I'll try eurocarparts & CES.

    Thanks,

    C
     
  8. SilverSaloon

    SilverSaloon MB Club Veteran

    Messages:
    7,759
    Joined:
    Mar 16, 2004
    Car:
    1994 W124 E300D Estate, 1985 R107 280SL
    i had this problem with my W124 (althoigh on a 124 the light resets itself), and my loose connection was at the buckle itself. The weld holding the wire in had come loose. A new buckle sorted it.
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.