Start up poor

Discussion in 'Engine' started by RobMorris, Aug 24, 2011.

  1. RobMorris

    RobMorris Active Member

    Messages:
    72
    Joined:
    Feb 8, 2011
    Location:
    Aveley, essex
    Car:
    W210 E300 TD
    Chaps

    When I first start the car, the engine seems to struggle to fire up and tick over / It sounds horrible etc

    But after about 5 seconds, it seems to have coughed it through and then runs fine?

    What could it be?
    The previous owner said it just needs a service and nes glow plugs?

    Cheers
     
  2. Dieselman

    Dieselman Banned

    Messages:
    34,206
    Joined:
    Jul 13, 2003
    Car:
    Peugeot 403 Convertible
    If the glowplug light comes back on after starting then one or more plugs is down, if not, suspect air leaking into the clear plastic pipes.
     
  3. OP
    OP
    RobMorris

    RobMorris Active Member

    Messages:
    72
    Joined:
    Feb 8, 2011
    Location:
    Aveley, essex
    Car:
    W210 E300 TD
    are the pipes an easy/cheap fix?
     
  4. Dieselman

    Dieselman Banned

    Messages:
    34,206
    Joined:
    Jul 13, 2003
    Car:
    Peugeot 403 Convertible
    About £35 and easy to do.
     
  5. OP
    OP
    RobMorris

    RobMorris Active Member

    Messages:
    72
    Joined:
    Feb 8, 2011
    Location:
    Aveley, essex
    Car:
    W210 E300 TD
    Cool - would you have a link to what I need and to purchase?
     
Tags:

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.