strange chirp sound from engine

Discussion in 'New member introductions' started by crisoton, Aug 9, 2011.

  1. crisoton

    crisoton New Member

    Messages:
    11
    Joined:
    Nov 20, 2010
    hi i have this problem on my w203 c200cdi, ive recently been experinsing this chirping niose from the engine when im driving it kicks in around 2000rpm then goes when i accellerate through , ive changed my belt tensioner pully, idler pully, also new waterpump checked all pulleys for movement n play seem ok, heard about the clutchpully on alternator seems to freewheel fine also took airfilter box off to check rubber mounts they ok cant seem to find the cause, any info would be ace as im at my wits ends cheers chris
     
  2. Bobby Dazzler

    Bobby Dazzler MB Club Veteran

    Messages:
    15,393
    Joined:
    Jan 21, 2005
    Location:
    Mittel England
    Car:
    ML AMG-line Black Series
    Is it when you remove your foot from the accelerator? If so then it could be your wastegate leaking boost (by design).

    More of a Mewww than a Chirp though. Still a cuddly animal noise that sounds odd. :D
     
  3. OP
    OP
    crisoton

    crisoton New Member

    Messages:
    11
    Joined:
    Nov 20, 2010
    its like a chirp it comes n goes seems to be a shallow sound then when i press the pedal it gets louder the slowly fades but it doesnt happen all the time its hard to explain its intermittant
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.