strange chirp/sqeaul sound from engine intermittant

Discussion in 'Engine' started by crisoton, Aug 10, 2011.

  1. crisoton

    crisoton New Member

    Messages:
    11
    Joined:
    Nov 20, 2010
    hi i have this problem on my w203 c200cdi, ive recently been experinsing this chirping niose from the engine when im driving it kicks in around 2000rpm then goes when i accellerate through , ive changed my belt , tensioner pully, idler pully, also new waterpump checked all pulleys for movement n play seem ok, heard about the clutchpully on alternator seems to freewheel fine also took airfilter box off to check rubber mounts they ok cant seem to find the cause, any info would be ace
     
  2. Ted

    Ted MB Enthusiast

    Messages:
    5,758
    Joined:
    Feb 26, 2004
    Location:
    Bourton on Dunsmore
    Car:
    SLC 250D AMG Line, Yamaha XVS 1100, Jeep Renegade
    Leak from an injector?
    I would expect to see crud around the injectors if this were the case.
     
  3. OP
    OP
    crisoton

    crisoton New Member

    Messages:
    11
    Joined:
    Nov 20, 2010
    changed all injector seals not that as u would hear that on tick over
     
  4. 142 TPL

    142 TPL Active Member

    Messages:
    138
    Joined:
    Aug 30, 2009
    I get a chirp from mine if I boot it hard. Just as it comes on full boost it's sounds like the belt slips for about 1second then it's gone. Does it in hot weather never in the rain. I have put it down to belt slip on the alternator pulley as this pulley is very shiny looking as if it has been slipping
     
  5. OP
    OP
    crisoton

    crisoton New Member

    Messages:
    11
    Joined:
    Nov 20, 2010
    just tried mine again and its doing it in the rain ???? its starting to pee me off now
     
  6. OP
    OP
    crisoton

    crisoton New Member

    Messages:
    11
    Joined:
    Nov 20, 2010
    ok ive done a small vid for you to hear Merc w203 cdi engine strange chirp sound - YouTube also this niose only appears when im doing just over 2000rpm then stops after 3-4000rpm please note itsa intermittant, also before i get replies ive changed the following : v belt , belt tensioner, idler pully, waterpump, ive also checked the other pullys no sign off play in them ?? any ideas some one must know
     
  7. artyman

    artyman MB Enthusiast

    Messages:
    2,162
    Joined:
    Mar 4, 2011
    Location:
    Hampshire
    Car:
    C 200 CDI Sport
    It sounds like a clutch thrust bearing to me, not sure if it's pertinent to an auto though.
     
  8. renault12ts

    renault12ts MB Club Veteran

    Messages:
    16,100
    Joined:
    Mar 5, 2009
    Car:
    2005 W215 CL500.
    Don't know if you got this sorted. But it has started on mine. It's the alternator pulley on it's way out. There is a clutch in the pulley, so it chirps as it engages.
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.