strange chirp/sqeaul sound from engine intermittant

crisoton

New Member
Joined
Nov 20, 2010
Messages
11
hi i have this problem on my w203 c200cdi, ive recently been experinsing this chirping niose from the engine when im driving it kicks in around 2000rpm then goes when i accellerate through , ive changed my belt , tensioner pully, idler pully, also new waterpump checked all pulleys for movement n play seem ok, heard about the clutchpully on alternator seems to freewheel fine also took airfilter box off to check rubber mounts they ok cant seem to find the cause, any info would be ace
 

Ted

MB Enthusiast
Joined
Feb 26, 2004
Messages
6,187
Location
Bourton on Dunsmore
Car
Lexus RC300h F-Sport, Yamaha XVS 1100, Jeep Renegade
Leak from an injector?
I would expect to see crud around the injectors if this were the case.
 
OP
OP
C

crisoton

New Member
Joined
Nov 20, 2010
Messages
11
changed all injector seals not that as u would hear that on tick over
 

142 TPL

Active Member
Joined
Aug 30, 2009
Messages
138
I get a chirp from mine if I boot it hard. Just as it comes on full boost it's sounds like the belt slips for about 1second then it's gone. Does it in hot weather never in the rain. I have put it down to belt slip on the alternator pulley as this pulley is very shiny looking as if it has been slipping
 
OP
OP
C

crisoton

New Member
Joined
Nov 20, 2010
Messages
11
just tried mine again and its doing it in the rain ???? its starting to pee me off now
 
OP
OP
C

crisoton

New Member
Joined
Nov 20, 2010
Messages
11
ok ive done a small vid for you to hear Merc w203 cdi engine strange chirp sound - YouTube also this niose only appears when im doing just over 2000rpm then stops after 3-4000rpm please note itsa intermittant, also before i get replies ive changed the following : v belt , belt tensioner, idler pully, waterpump, ive also checked the other pullys no sign off play in them ?? any ideas some one must know
 

artyman

MB Enthusiast
SUPPORTER
Joined
Mar 4, 2011
Messages
2,498
Location
Hampshire
Car
Kia E-Niro ex C 200 CDI Sport
It sounds like a clutch thrust bearing to me, not sure if it's pertinent to an auto though.
 

renault12ts

MB Club Veteran
Joined
Mar 5, 2009
Messages
16,493
Car
2005 W215 CL500.
Don't know if you got this sorted. But it has started on mine. It's the alternator pulley on it's way out. There is a clutch in the pulley, so it chirps as it engages.
 

Users who are viewing this thread

Top Bottom