Strange thing happened today

Discussion in 'AMG Lounge' started by bluestreak, Apr 22, 2017.

  1. bluestreak

    bluestreak Active Member

    Messages:
    396
    Joined:
    Jun 13, 2016
    Location:
    London
    Car:
    2015 E63
    My s212 e63 threw a wobbly today. There was suddenly quite a lot of vibration thru the drivetrain under medium acceleration. Engine light has come on. I pulled over, stopped the engine and before calling recovery I decided to start it up again and check under the bonnet for anything obvious. Engine started ok, vibration has gone and so did the engine light.

    Does this problem sound familiar to anybody? Can this be software glitch?

    Following this incident we decided to go back home, which was about 10 miles. The problem has never reoccurred. I'm now reluctant to drive the car again before this issue is understood. Any ideas?
     
  2. st13phil

    st13phil MB Enthusiast

    Messages:
    8,182
    Joined:
    Nov 6, 2007
    Location:
    North Oxfordshire
    Car:
    His - Denim Blue A220 AMG Line Premium / Hers - Obsidian Black R172 SLK55
    You'll need to get the stored fault codes read to get any idea of what the cause of the problem was / is.
     
  3. -AJC-

    -AJC- Active Member

    Messages:
    74
    Joined:
    Dec 16, 2014
    Location:
    Surrey
    Car:
    ML 320 CDI
    Coil pack?
     
  4. Steveml63

    Steveml63 MB Enthusiast

    Messages:
    1,234
    Joined:
    Jun 6, 2015
    Location:
    Sunny Abu Dhabi
    Car:
    ML63 AMG
  5. OP
    OP
    bluestreak

    bluestreak Active Member

    Messages:
    396
    Joined:
    Jun 13, 2016
    Location:
    London
    Car:
    2015 E63
    thanks a lot gents, i have to add that car is at 12k miles.

    Phil, Is there DIY method to check for error codes? Car is booked in, but that's three weeks away :( Fingers crossed somebody can check them out tomorrow at Benz on the green.

    Crankshaft position sensor error symptoms sound very similar to what happened today, thanks Steve! I hope this is it and it'll be replaced under warranty.

    Is coil pack issue a known problem on these engines?
     
  6. AMGeed

    AMGeed Hardcore MB Enthusiast

    Messages:
    13,029
    Joined:
    Nov 1, 2008
    Location:
    Bournemouth/Poole Dorset
    Car:
    2014 E63 Biturbo
    The Benz on the Green GTG isn't until Sat 13th May:dk:

    Got to say I have had two crank sensors fail and neither gave the same symptoms as you describe. Engine simply fails to start when hot and when cooled down will start again.
    A coil pack is a possibility but I would have thought a constant fault and not one that would disappear when restarting.

    As Phil mentioned, the stored fault code should point to the problem.

    I see you are based in London. I would give Terry at Wayne Gates a call and see if he could take a look instead of waiting 3 weeks. He is Harrow.

    Wayne Gates Specializing in Mercedes Benz
     
  7. OP
    OP
    bluestreak

    bluestreak Active Member

    Messages:
    396
    Joined:
    Jun 13, 2016
    Location:
    London
    Car:
    2015 E63
    What was i thinking :dk:

    Very helpful to know there is a good garage in harrow, i'll give them a call on Monday.
     
  8. AMGBlack

    AMGBlack Active Member

    Messages:
    345
    Joined:
    Jul 10, 2010
    Location:
    Bristol & Ottawa (Canada)
    Car:
    E63S (Black)
    Yes, I have had this happen.
    In my CL63 (Same Engine) it was indeed a Knock Sensor that had a fit (according to the dealership when they looked at the fault codes).
    Happened when I went to overtake someone so it was not the best time to happen. It happened twice and never repeated itself ever..
    The dealership said these sensors are so over sensitive sometimes and it shut down a complete "bank" of cylinders, hence the really rough running for a while.

    Just like you, stopped the car.. restarted it and it was fine.

    But what do I know, thats what the dealership said.
    I could have run over someone I guess..
     
  9. OP
    OP
    bluestreak

    bluestreak Active Member

    Messages:
    396
    Joined:
    Jun 13, 2016
    Location:
    London
    Car:
    2015 E63
    That is unfortunate. At least I wasn't in opposite lane when this happened. Did they end up replacing the sensor?
     
  10. Hazman

    Hazman New Member

    Messages:
    6
    Joined:
    Jul 15, 2015
    Location:
    Midlands
    Car:
    CLS63 SB, Honda NSX, Subaru Forester 270
    Exact same thing happened to me a few times, code was mis-fire in one of the cyls. After coil packs swapped around and symptoms reappeared, was diagnosed as a faulty injector. Now replaced,and no reoccurrence...
     
    2 people like this.
  11. OP
    OP
    bluestreak

    bluestreak Active Member

    Messages:
    396
    Joined:
    Jun 13, 2016
    Location:
    London
    Car:
    2015 E63
    Finally had car on xentry today and it was knock sensor after all.

    Dealer made a thing out of giving me xentry report printout. What are they hiding exactly?
     
  12. developer

    developer MB Enthusiast

    Messages:
    8,202
    Joined:
    Dec 28, 2007
    Car:
    S212 E63 S
    What do you mean?
     
  13. OP
    OP
    bluestreak

    bluestreak Active Member

    Messages:
    396
    Joined:
    Jun 13, 2016
    Location:
    London
    Car:
    2015 E63
    They did xentry printout and service person quickly went over paragraph highlighting "ticks" against each. It is over 10 pages of details on various systems and I wanted to keep this paper so I could spend longer than 60 seconds with these. Service guy refused and said that it is against their rules. Question really is if this normal response and if it is at all possible to get hold of such printout for my own car?
     
  14. markjay

    markjay MB Club Veteran

    Messages:
    24,867
    Joined:
    Jun 24, 2008
    Location:
    London
    Car:
    W204 C180 Executive SE 2013 Automatic / COMAND NTG4.7 and Morel speakers fitted by www.comand.co.uk
    If you paid for diagnosis, you are entitled to the printout.

    If it was done under warranty, then they will usually be very tight fisted with any documentation.

    (I managed on previous occasions to get a friendly receptionist to photocopy the internal job sheet etc for me, but officially they give you nothing other than "We got it all sorted for you, Sir".
     
  15. OP
    OP
    bluestreak

    bluestreak Active Member

    Messages:
    396
    Joined:
    Jun 13, 2016
    Location:
    London
    Car:
    2015 E63
    It was under warranty and this is exactly what happened. Thank you for explaining!
     
  16. Jasons69

    Jasons69 Member

    Messages:
    50
    Joined:
    Dec 23, 2016
    Car:
    E220 bluetec
    Similar but irrelevant but I had to call out MB Assist this morning, EML light and reduced performance.

    Guy came out and reset, but if it does need to go to a garage he said they are normally fast tracked through. Cant comment obviously as car was sorted in the office car park.

    J
     
  17. Yugguy

    Yugguy MB Enthusiast

    Messages:
    2,257
    Joined:
    Apr 6, 2016
    Location:
    Rugby UK
    Car:
    W204 C220CDI Elegance with Comand
    Spend 100 quid on an MBII, it'll be worth it especially if you are going to keep the car for a while.
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.