Telephone in an S430 W220

Discussion in 'Electronics' started by V8Rumble, Nov 10, 2014.

  1. V8Rumble

    V8Rumble New Member

    Messages:
    27
    Joined:
    Sep 24, 2014
    Location:
    Northants
    Car:
    S430, 1966 Pontiac Ventura, Cosworth powered MK2 Granada
    I have the dreaded battery drain and have got hold of a WIS but before I start having to take trim off to disconnect plugs etc I thought I would disconnect the telephone as it is a known culprit. I have took the command unit out and still have a drain.

    So my question is where is the connector for the telephone?
     
  2. Diesel Benz

    Diesel Benz MB Enthusiast

    Messages:
    4,088
    Joined:
    Feb 3, 2006
    Location:
    Europe
    Car:
    222.132 & 221.122 & 213.050 & 906.633
    Which phone option do you have? An example here: ar82.70-p-7379i. I guess the location of the control unit is about the same for all options.

    Why don't you follow the fuse chart instead and pull the fuse? Easier than unplugging the control unit connectors? On the fibre ring one should bypass the fibre to make the rest of the ring operational but that did not happen anyway when you removed the head unit.
     
  3. OP
    OP
    V8Rumble

    V8Rumble New Member

    Messages:
    27
    Joined:
    Sep 24, 2014
    Location:
    Northants
    Car:
    S430, 1966 Pontiac Ventura, Cosworth powered MK2 Granada
    Just going to have a look. I have isolated it to fuse 61 which is the Command but as mentioned no joy when whole unit removed. When I pull the fuse I also loose the central locking but still no joy with the locking pump disconnected so that's why I needed the wiring diagrams on the WIS.

    Fuse 61 circuit is connected to three Z connectors so that is my next port of call but I thought on the off chance I might get lucky and not have to remove trim etc.

    Just trying to get my head round this canbus thing.
     
  4. OP
    OP
    V8Rumble

    V8Rumble New Member

    Messages:
    27
    Joined:
    Sep 24, 2014
    Location:
    Northants
    Car:
    S430, 1966 Pontiac Ventura, Cosworth powered MK2 Granada
    I have been informed by Olly who is an independant Merc dealership down south (forget his user name) that Z connections are all soldered so unlikely to be the problem.

    I have gone to the rear fuse box to fuse 61 and the two red and yellow wires exiting the fuse has had bullet connectors crimped in line so obviously someone has been investigating the problem.

    When I disconnect the smaller gauge wire there is no effect on the current drain but if I disconnect the other one the drain stops but so does the door locking along with the Command.

    The led's light up on the ABC switch and the one next to it with the car picture and an up and down arrow. I cannot switch the led's off and they extinguish as soon as the wire is reconnected.

    Having looked at the wiring diagram I cannot see where the door locking or anything else is directly connected.

    Whilst under the back seat I disconnected every plug near the fuse box but still no difference in the drain.

    Any ideas???????????

    Forgot to say it is a 2000 plate
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.