ticking noise on the dashboard

Discussion in 'Electronics' started by Rigkraft, Apr 5, 2014.

  1. Rigkraft

    Rigkraft New Member

    Messages:
    14
    Joined:
    Apr 5, 2014
    Car:
    mb cdi 220 coupe
    Hi every,
    sorry my first post is a question, I just bought my first Mercedes last night , and when you first switch on the ignition there is a noise like a loud clock ticking in the dashboard , to the left of the instruments , the car is a a 220cdi diesel , is this something to worry about ?

    thanks in advance for any help

    Shane
     
  2. grumpyoldgit

    grumpyoldgit Hardcore MB Enthusiast

    Messages:
    2,604
    Joined:
    May 7, 2012
    Location:
    Stourbridge
    Car:
    C270CDI Avantgarde SE
    Does the clicking stop after a few minutes?

    It could be the dreaded heater flaps problem. Plenty of posts on here about the problem, do a search.
     
  3. OP
    OP
    Rigkraft

    Rigkraft New Member

    Messages:
    14
    Joined:
    Apr 5, 2014
    Car:
    mb cdi 220 coupe
    I think you could be right Mr G , at least it isn't anything major , I didn't notice the "search" button

    Thank you

    Shane
     
  4. grumpyoldgit

    grumpyoldgit Hardcore MB Enthusiast

    Messages:
    2,604
    Joined:
    May 7, 2012
    Location:
    Stourbridge
    Car:
    C270CDI Avantgarde SE
    You could try resetting the heater flaps, might be worth a go...

    To reset heater flaps and actuators

    Switch on ignition.

    Press recirculated air and defrost buttons on control panel together for longer than 5 seconds.

    The LED's in the defrost and recirculated air buttons flash alternately.

    Wait until the LED's stop flashing (approx 30 sec) system set to defrost LED on.

    Switch off ignition.

    After 40 sec re start engine.
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.