top radiator hose collapsed

Discussion in 'Engine' started by pimpmyc250td, Jun 28, 2011.

  1. pimpmyc250td

    pimpmyc250td Active Member

    Messages:
    83
    Joined:
    Apr 8, 2011
    Location:
    republic of mancunia
    Car:
    c250tdw202
    hi

    just found the top hose on my c250td flat rather than round,as if the system has a vacuum, car is not losing fluid temp never gets above 80

    i changed the expansion cap last week, so is this related ( just put the old one back on)... hose is now back in shape, after taking the expansion cap off ....is it a sign of an underlying problem....

    top hose is still warm, bottom cold , radiator cold,

    I was planning a system flush out at some point should i change the thermostat too, and get on with the flusing???
     
  2. Mercsys

    Mercsys Hardcore MB Enthusiast

    Messages:
    251
    Joined:
    Apr 5, 2011
    Location:
    West London, UK
    Car:
    S350, & E320 CDI Estate Avantgarde
    Looks like the new cap is not rated to the correct spec, or may be faulty, there is usualy a very low neg pressure rating spec. The new cap doesent seem to be doing what is needed, your hoses wont like being squashed and then pressurised.
     
  3. OP
    OP
    pimpmyc250td

    pimpmyc250td Active Member

    Messages:
    83
    Joined:
    Apr 8, 2011
    Location:
    republic of mancunia
    Car:
    c250tdw202
    Thanks...new cap was source
    From ecp...I will pick up a New mb cap, and swap out the top hose as its very soft
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.