turbo prblems on c200 cdi (2004) 54 plate

Discussion in 'Engine' started by itsabeauty, Oct 12, 2011.

  1. itsabeauty

    itsabeauty New Member

    Messages:
    1
    Joined:
    Oct 12, 2011
    Car:
    c200 cdi
    Hi, I have a c200 CDI on a 54 plate.
    It has done 79k miles and has developed a fault with the turbo tonight.
    It sounds like the passenger window is open when you put your foot on the gas, like a leaking pipe pouring out air. After about 5 mins the car suddenly loses power and wont go above 3000 rpm however no engine management lights come on. It sounds as if the turbo has stopped spinning maybe due to not enough pressure?

    I though I had split a pipe however the hissing noise seems to be coming from under the the passenger side rather than the turbo......

    I have had the engine cowling off and been revving it but still seems from the underside of the car?

    Any comments would be much appreciated.

    Thanks
    Nick
     
  2. Henry D

    Henry D Active Member

    Messages:
    216
    Joined:
    Sep 30, 2011
    Location:
    west cornwall
    Car:
    2002 CLK 230K avantguarde
    If its coming from underneath the car it could be an exhaust blockage/cat breaking up
     
  3. tonysmb

    tonysmb Active Member

    Messages:
    401
    Joined:
    Oct 11, 2011
    Location:
    South
    Car:
    MB
    Have you checked that the pipes are still properly attached?
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.